【问题标题】:HTTP 500 Internal Server Error with special signs URL带有特殊符号 URL 的 HTTP 500 内部服务器错误
【发布时间】:2018-10-13 06:40:12
【问题描述】:

我为我的 SPA 开发了一个 Laravel API。有时我使用查询参数向 API 提供数据。但是,如果 API URL 中有 @ 符号,则服务器会以 500 - Internal Server Error 进行响应。示例...

这里会报错:

http://www.mywebsite.com/api/user/login?name=example.user@gmail.de&password=changeMe

这里一切正常:

http://www.mywebsite.com/api/user/login?name=exampleUser&password=changeMe

本地两种方式都有效。但是在直播服务器上测试时发生了错误。

有谁知道问题出在哪里?如果有帮助,我正在使用带有 Plesk 的 Apache 服务器。 ;-)

【问题讨论】:

    标签: laravel apache server special-characters


    【解决方案1】:

    好的,我已经解决了这个问题。如果其他人有同样的错误:

    只需将服务器端默认字符集设置为 utf-8 即可解决该问题!

    【讨论】:

      猜你喜欢
      • 1970-01-01
      • 1970-01-01
      • 2012-02-23
      • 1970-01-01
      • 1970-01-01
      • 1970-01-01
      • 1970-01-01
      • 2017-07-16
      • 1970-01-01
      相关资源
      最近更新 更多