【发布时间】:2018-02-13 08:59:54
【问题描述】:
我正在将我的单片 JHipster 应用程序部署到 Tomcat。我已将弹性搜索作为服务安装,以便将其用作我的应用程序的单独节点。 弹性搜索工作正常(localhost:9200 返回集群信息)。
我将此配置添加到我的 application-prod.yml
data:
elasticsearch:
cluster-name: elasticsearch
cluster-nodes: localhost:9300
properties:
http:
enabled: true
当我启动 tomcat 时出现此错误:
.AbstractElasticsearchRepository : failed to load elasticsearch nodes : org.elasticsearch.client.transport.NoNodeAvailableException: None of the configured nodes are available: [{#transport#-1}{localhost}{127.0.0.1:9300}]
【问题讨论】:
-
您尝试使用哪个版本的 elasticsearch?
-
另外,你在哪里部署Tomcat?在本地还是在 AWS 之类的地方?
标签: tomcat elasticsearch jhipster