【问题标题】:Elastic search - Spring boot: None of the configured nodes are available弹性搜索 - Spring boot:配置的节点均不可用
【发布时间】:2018-02-13 08:59:54
【问题描述】:

我正在将我的单片 JHipster 应用程序部署到 Tomcat。我已将弹性搜索作为服务安装,以便将其用作我的应用程序的单独节点。 弹性搜索工作正常(localhost:9200 返回集群信息)。

我将此配置添加到我的 application-prod.yml

  data:
    elasticsearch:
        cluster-name: elasticsearch
        cluster-nodes: localhost:9300
        properties:
            http:
                enabled: true

当我启动 tomcat 时出现此错误:

   .AbstractElasticsearchRepository : failed to load elasticsearch nodes : org.elasticsearch.client.transport.NoNodeAvailableException: None of the configured nodes are available: [{#transport#-1}{localhost}{127.0.0.1:9300}]

【问题讨论】:

  • 您尝试使用哪个版本的 elasticsearch?
  • 另外,你在哪里部署Tomcat?在本地还是在 AWS 之类的地方?

标签: tomcat elasticsearch jhipster


【解决方案1】:

我找到了解决办法,我使用了错误版本的 elasticSearch。

根据this,我必须使用 2 到 5 之间的版本,因为我正在使用 spring boot 1.5。

【讨论】:

    猜你喜欢
    • 2018-02-01
    • 2018-06-08
    • 2014-11-04
    • 2020-10-22
    • 1970-01-01
    • 1970-01-01
    • 2016-08-22
    • 1970-01-01
    • 1970-01-01
    相关资源
    最近更新 更多