【问题标题】:running multiple instance of tomcat运行多个tomcat实例
【发布时间】:2014-02-19 19:10:31
【问题描述】:

我正在尝试在我的wondows 系统中安装tomcat 7。我安装了 tomcat 6.0.35,它正在工作。但是我无法安装tomcat 7。

我已经更改了端口号。

对于tomcat 6.0.35,

Server port="8105" , Connector port="8181", AJP 1.3 port="8109"

这是有效的(在 localhost 8181)。

对于tomcat 7.0.23

Server port="8106" , Connector port="8182", AJP 1.3 port="8110"

tomcat 7 没有运行,startup.bat 文件正在运行,但是tomcat 主页没有在浏览器中显示。

这是日志

Feb 19, 2014 4:21:30 PM org.apache.catalina.startup.Catalina start
SEVERE: Catalina.start: 
org.apache.catalina.LifecycleException: Failed to start component      [StandardServer[8106]]
at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:154)
at org.apache.catalina.startup.Catalina.start(Catalina.java:624)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)   
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:601)
at org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:322)
at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:450)
Caused by: org.apache.catalina.LifecycleException: Failed to start component [StandardService[Catalina]]
at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:154)
at org.apache.catalina.core.StandardServer.startInternal(StandardServer.java:727)
at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:150)
... 7 more
Caused by: org.apache.catalina.LifecycleException: Failed to start component [StandardEngine[Catalina]]
at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:154)
at org.apache.catalina.core.StandardService.startInternal(StandardService.java:443)
at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:150)
... 9 more
Caused by: org.apache.catalina.LifecycleException: A child container failed during start
at org.apache.catalina.core.ContainerBase.startInternal(ContainerBase.java:1108)
at org.apache.catalina.core.StandardEngine.startInternal(StandardEngine.java:291)
at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:150)
... 11 more

我不知道出了什么问题。

【问题讨论】:

标签: tomcat


【解决方案1】:

下面的链接有助于配置这个:

https://tomcat.apache.org/tomcat-7.0-doc/RUNNING.txt

【讨论】:

    猜你喜欢
    • 2017-06-08
    • 1970-01-01
    • 2015-04-24
    • 1970-01-01
    • 1970-01-01
    • 2021-02-01
    • 2014-11-23
    • 2018-02-06
    • 2013-11-28
    相关资源
    最近更新 更多