【问题标题】:VPS SERVER CONFIGURATIONVPS 服务器配置
【发布时间】:2016-10-01 05:10:17
【问题描述】:

我从 bluehost 购买了一个新的 vps 服务器,我需要将我的 api 数据获取站点移动到 vps 服务器上。我的 api 站点是用 php 开发的,mysql 用 json 请求开发的。

使用 json 通过 API 获取数据并插入到 mysql 数据库中。当我运行我的网站时,我经常得到 ​​p>

内部服务器错误

服务器遇到内部错误或配置错误,无法完成您的请求。

请联系服务器管理员 webmaster@offerlinx.com 并告知他们错误发生的时间,以及您所做的任何可能导致错误的事情。

服务器错误日志中可能会提供有关此错误的更多信息。

此外,在尝试使用 ErrorDocument 处理请求时遇到 500 Internal Server Error 错误。

请指导我在 vps 服务器中配置哪些基本内容才能从 APi 获取 mre 数据。

提前致谢

【问题讨论】:

  • 检查日志文件
  • 您好,我已经检查了error_log,它只有通知和警告。它与内部服务器错误权限无关
  • 你有没有nginx服务器的apcahe。
  • 我有 apache 服务器(来自 Blue Host 的 VPS)
  • 希望你检查过 apache 日志。

标签: php mysql json vps


【解决方案1】:

发生错误是因为在您将 API 数据提取到新 VPS 时丢失了一些数据。

您可以检查服务器内部服务器日志并检查确切的错误。此外,您可以简单地关闭 CustomError 模式并查找错误。

如果您没有发现上述建议的错误,您可以联系您的新 VPS 托管服务提供商。他们将完全能够回答您的疑问和错误。

希望对你有帮助。

【讨论】:

    猜你喜欢
    • 2020-04-17
    • 2011-02-10
    • 2016-04-24
    • 1970-01-01
    • 1970-01-01
    • 2021-01-08
    • 2012-04-28
    • 1970-01-01
    • 1970-01-01
    相关资源
    最近更新 更多