【问题标题】:There was an error while restarting Apache Service on Webuzo Panel在 Webuzo 面板上重新启动 Apache 服务时出错
【发布时间】:2017-11-27 05:59:55
【问题描述】:

我遇到了无法重新启动 apache 服务器或启动它的问题。错误显示“执行操作时出错”。我不知道是什么导致了这个问题。

也许有人可以帮我解决这个问题? 谢谢。

编辑:: 操作系统发行版:CentOS 6 64bit Apache 版本:Apache/2.2.31 (Unix) DAV/2 mod_ssl/2.2.31 OpenSSL/1.0.1u mod_wsgi/4.4.22 Python/2.7.11

【问题讨论】:

  • 添加更多信息,例如您的 apache 版本、操作系统发行版和版本以及 apache 错误日志的最后几行。如果没有自定义,apache错误日志可能在:/var/log/apache2/error.log
  • @KanujBhatnagar 我更新了我的问题,但我没有找到你建议的目录
  • 能否运行以下命令:tail -f /var/logs/httpd/error_log 并在此处发布最后几行的内容?
  • @KanujBhatnagar 这个输出 -> 尾部:无法打开 `/var/logs/httpd/error_log' 进行阅读:没有这样的文件或目录尾部:没有剩余文件
  • 以前,我被删除了 error_log 和 /usr/local/apps/apache/logs/ 中的所有日志文件,因为它占用了很多空间。所以,我决定删除它,然后当我想通过 webuzo 重新启动 apache 服务时它不起作用

标签: php apache vps


【解决方案1】:

我只是重新启动我的 vps,然后再次正常工作。 所以可能是因为有些配置不正确。

【讨论】:

  • 为了将来参考,您可能需要再次启用您的日志。不建议删除它们,下次你的 apache 无法重新启动时,你会在调试时遇到麻烦。
  • @KanujBhatnagar 如何启用它?只需通过命令 touch error_log ?
【解决方案2】:

首先,通过执行以下命令检查80端口上是否有任何服务运行

lsof -i:80

如果你发现了什么就杀了它

kill -9(processid)

现在运行以下命令重新启动 apache:

service httpd restart

此命令适用于 Centos 和 ubuntu。

如果仍然没有启动 apache,那么您可以检查位于的 apache 日志

/var/log/apache/

【讨论】:

    猜你喜欢
    • 1970-01-01
    • 1970-01-01
    • 2014-02-20
    • 1970-01-01
    • 2020-09-14
    • 1970-01-01
    • 2013-06-29
    • 2015-12-29
    • 2019-05-07
    相关资源
    最近更新 更多