【问题标题】:Deployment of api created in lumen at aws server在 aws 服务器上部署在 lumen 中创建的 api
【发布时间】:2018-08-03 07:56:45
【问题描述】:

我在常规程序中部署项目,但这次在 aws 部署时遇到了一些错误。我使用 ssh 命令和 ubuntu 16.04 的密钥对在那里部署。我在那里成功安装了lamp、PHP和PHPMyAdmin。

这是我面临的链接和错误http://52.60.197.219/api/category,它说找不到错误 404 我尝试了几乎所有可用的解决方案,但没有成功。

我们将不胜感激。

my.htaccess 文件 ` 选项 - 多视图

RewriteEngine On

# Redirect Trailing Slashes If Not A Folder...
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)/$ /$1 [L,R=301]

# Handle Front Controller...
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule ^ Api_load.php [L]

# Handle Authorization Header
RewriteCond %{HTTP:Authorization} .
RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

`

我的 index.php 文件名为 Api_load.php $app = require __DIR__.'/api/bootstrap/app.php'; $app->run();

已部署应用程序的结构 API(文件夹包含所有文件和代码) .htaccess, api_load.php

【问题讨论】:

  • 检查Apache重写模式是否开启
  • 它已经启用了!请问还有其他建议吗?
  • 目录权限必须是777
  • 其他所有内容都可以访问,但只有包含 .htaccess 和 index.php 的公用文件夹无法访问。 52.60.197.219/api/public/category api 是包含所有代码的文件夹名称
  • 您使用的是哪个流明版本?以及您的服务器中的哪个 php 版本?还要检查 apache 错误日志。

标签: php amazon-web-services amazon-ec2 ubuntu-14.04 lumen


【解决方案1】:

是的,这是一个常见错误。这都是因为 .htaccess 文件冲突。 按着这些次序。 1)创建文件夹的 Zip 并解压缩到您要部署代码的目录中。 2)根据您的要求编辑您的 .env 文件,即更改 Db 用户名、密码和数据库名称。 3).htaccess文件和public文件夹下的index文件,放到根目录外。 4)现在访问您的 baseUrl/端点名称。 它会起作用的。

【讨论】:

  • 好吧,让我试试!
【解决方案2】:

尝试通过将以下配置添加到/etc/apache2/apache2.conf 或site-avaliable/000-default.conf 来解决您的问题,然后重新启动apache2。

<Directory /home/away/workspace/park/public>
    Options Indexes FollowSymLinks
    AllowOverride All
    Require all granted
</Directory>

【讨论】:

猜你喜欢
  • 1970-01-01
  • 1970-01-01
  • 1970-01-01
  • 2019-09-22
  • 1970-01-01
  • 1970-01-01
  • 1970-01-01
  • 2019-01-06
  • 2021-01-04
相关资源
最近更新 更多