【问题标题】:TFS access denied to only one specific domain user仅对一个特定域用户拒绝 TFS 访问
【发布时间】:2010-08-30 18:47:21
【问题描述】:

我创建了一个本地组用户,并将其添加到 TFS 参与者/有效用户组。任何时候如果我需要添加一个用户作为贡献者,我会把他/她添加到本地组,这个人可以访问 TFS;直到现在。最近雇用了一个新人,MIS 为他设置了域帐户。我以同样的方式添加了他,但由于某种原因他无法连接到 TFS。我尝试了我所知道的一切。我什至要求 MIS 在 ADS 中重新创建(删除并重新创建)用户。但似乎没有任何效果。有人知道可能是什么问题吗?

【问题讨论】:

  • 您在 TFS 上有多少用户(不包括刚入职的用户)?
  • 24.但我也添加了另外两个新用户。他们有权访问。

标签: tfs active-directory connection privileges


【解决方案1】:

我遇到了同样的问题,即用户在将 hem/her 添加到用户组时没有获得 TFS 的权限。我通过将用户直接添加到 TFS 来解决它。您可以使用 TFS 管理工具将用户快速添加到 TFS、SSRS 和 Sharepoint:http://tfsadmin.codeplex.com

【讨论】:

  • OK.. 我也遇到过同样的问题。我认为这也是因为一些缓存。但修复很容易。当您使用系统本地组(Window 组)对用户进行分组并将其添加到 TFS 组时,每当您通过添加新用户或删除现有用户来刷新本地组时,您需要从 TFS 中删除整个组,然后添加又来了。
【解决方案2】:

好的。我解决了这个问题。导致此问题的是 TFS 缓存。一旦我清除它,一切正常。

感谢您的帮助。

【讨论】:

    猜你喜欢
    • 2018-03-27
    • 1970-01-01
    • 1970-01-01
    • 2015-05-28
    • 2011-12-13
    • 2011-01-12
    • 2015-08-09
    • 1970-01-01
    • 1970-01-01
    相关资源
    最近更新 更多