【问题标题】:How to bootstrap a MariaDB cluster on CentOS 7?如何在 CentOS 7 上引导 MariaDB 集群?
【发布时间】:2017-05-22 16:31:14
【问题描述】:

我已经查阅了三个使用 Galera 复制设置 MariaDB 集群的指南,但无法启动它。

我在 CentOS 7 上并选择从其官方存储库安装 MariaDB 10.1。我遵循的指南都略有不同,它们的步骤都对我不起作用。

我已查阅 MariaDB 的 getting started with MariaDB Galera cluster 指南

发布galera_new_cluster 在我的第一个节点上启动 MariaDB。但是启动其他节点只是正常启动它们。查询SHOW STATUS LIKE 'wsrep_%'; 显示集群大小为0,状态为Disconnected。

我也咨询了Digital Oceans's guide for Ubuntu,得到了同样的结果。

由于我在 CentOS 上,我还检查了 Linode's guide,除了它安装了 Percona XtraDB 软件包,因此 mysql@bootstrap 命令不适用。

在 CentOS 7 下使用 Maria DB 10.1 首次启动集群的正确步骤是什么?

【问题讨论】:

    标签: mysql mariadb replication galera


    【解决方案1】:

    启动 galera 集群上名为 bootstrap 的第一个节点

    服务 mysql 启动 --wsrep-new-cluster

    【讨论】:

      【解决方案2】:

      原来我的提供程序库路径错误。

      #wsrep_provider=/usr/lib/galera/libgalera_smm.so
      wsrep_provider=/usr/lib64/galera/libgalera_smm.so
      

      指向一个不存在的文件并没有引发任何错误,所以只是什么都不做。

      【讨论】:

        猜你喜欢
        • 2019-07-21
        • 2018-04-05
        • 1970-01-01
        • 1970-01-01
        • 1970-01-01
        • 1970-01-01
        • 2016-11-30
        • 1970-01-01
        • 2018-05-03
        相关资源
        最近更新 更多