【问题标题】:ODBC connection fails when running with SQL Server Agent使用 SQL Server 代理运行时 ODBC 连接失败
【发布时间】:2021-09-08 11:01:35
【问题描述】:

我已将 SSIS 包更改为使用 64 位 ODBC 连接而不是 32 位。

部署后它在手动执行包时工作正常,但在使用包运行 SQL Server 代理作业时失败:

发生 ODBC 错误 -1

和

尝试与数据库服务器建立开放式数据库连接 (ODBC) 连接时出错

和

对连接管理器 Athena West-1 64 位的 AcquireConnection 调用失败,错误代码为 0xC0014009。

这个错误的原因是什么?

【问题讨论】:

  • 请注意,此线程无助于解决问题:stackoverflow.com/questions/13943765/…
  • 目标是 SQL Server 数据库吗?
  • 包在 32 位时是否工作?如果你切换回 32 位,它可以工作吗?

标签: sql-server ssis odbc


【解决方案1】:

如果这不是 32/64 位问题,那么我会查看权限。

当您手动执行包并且它可以工作时,是因为您拥有正确的权限。

可能 SQL Server 代理服务凭据没有目标数据库的权限。

右键单击 Job > Properties > General > Owner,然后在此处更改 Owner。如果您的用户有权访问远程服务器并执行,请设置您的用户。

还要检查远程服务器上的用户有哪些权限。

只是猜测。

【讨论】:

  • 我如何检查它是否有正确的权限?
  • 问题是,使用 32 位 ODBC 连接时它工作正常,所以我看不出它怎么可能是权限问题?
猜你喜欢
  • 1970-01-01
  • 1970-01-01
  • 1970-01-01
  • 2011-08-15
  • 1970-01-01
  • 1970-01-01
  • 2012-02-28
  • 2011-07-17
  • 1970-01-01
相关资源
最近更新 更多