【发布时间】:2021-09-08 11:01:35
【问题描述】:
我已将 SSIS 包更改为使用 64 位 ODBC 连接而不是 32 位。
部署后它在手动执行包时工作正常,但在使用包运行 SQL Server 代理作业时失败:
发生 ODBC 错误 -1
和
尝试与数据库服务器建立开放式数据库连接 (ODBC) 连接时出错
和
对连接管理器 Athena West-1 64 位的 AcquireConnection 调用失败,错误代码为 0xC0014009。
这个错误的原因是什么?
【问题讨论】:
-
请注意,此线程无助于解决问题:stackoverflow.com/questions/13943765/…
-
目标是 SQL Server 数据库吗?
-
包在 32 位时是否工作?如果你切换回 32 位,它可以工作吗?
标签: sql-server ssis odbc