【问题标题】:phpMyAdmin: Delete button is not functioningphpMyAdmin:删除按钮不起作用
【发布时间】:2016-10-26 08:21:05
【问题描述】:

我在本地机器上安装了适用于 Windows 的 XAMPP v3.2.2,我无法通过 phpMyAdmin 从表中删除记录。

这是我得到的错误截图:http://i.imgur.com/xFAP8Hy.jpg。从我看到的情况来看,点击删除按钮时生成的SQL查询不正确,但我不知道如何解决。

可能是因为我更改了 my.ini 配置文件并设置了lower_case_table_names = 2?这是我对 my.ini 文件所做的唯一更改。

这是表结构:

--
-- Table structure for table `Followups`
--

CREATE TABLE `Followups` (
  `ID` int(10) UNSIGNED NOT NULL,
  `ContactID` int(10) UNSIGNED NOT NULL,
  `RMID` int(10) UNSIGNED NOT NULL,
  `Number` tinyint(3) UNSIGNED NOT NULL,
  `CreationDate` timestamp NOT NULL DEFAULT CURRENT_TIMESTAMP
) ENGINE=InnoDB DEFAULT CHARSET=utf8;

--
-- Indexes for table `Followups`
--
ALTER TABLE `Followups`
  ADD PRIMARY KEY (`ID`);

--
-- AUTO_INCREMENT for table `Followups`
--
ALTER TABLE `Followups`
  MODIFY `ID` int(10) UNSIGNED NOT NULL AUTO_INCREMENT;

我尝试在表名中仅使用小写字母来制作表的副本,并且我可以从该表中删除记录。所以我猜这个问题是由 my.ini 文件中的lower_case_table_names 参数引起的。关于我接下来可以做什么来解决这个问题而不必重命名我的所有表名的任何想法?

【问题讨论】:

  • 请在where后面写条件
  • sql 查询不是我写的。我知道它有错误,但是一旦我单击删除按钮就会生成它。

标签: mysql phpmyadmin xampp


【解决方案1】:

这不是 phpMyAdmin 的问题。这里删除是错误的。根据您的屏幕截图,sql 查询显示为“Delete FROM 'followups'” where limit 1” 但您没有 where 条件。这就是问题所在。

我认为您没有设置此表的主键

【讨论】:

  • 我认为这是一个 phpMyAdmin 问题,而是因为 phpMyAdmin 的 UI 中的一个元素没有做它应该做的事情,可能是因为 my.ini 文件中的一些设置。我为此表设置了一个主键。我将编辑问题并添加表格结构。
猜你喜欢
  • 1970-01-01
  • 2017-11-27
  • 1970-01-01
  • 1970-01-01
  • 1970-01-01
  • 1970-01-01
  • 2017-06-08
  • 2018-11-09
相关资源
最近更新 更多