【问题标题】:rmysql - Error: Can't initialize character set unknownrmysql - 错误:无法初始化未知字符集
【发布时间】:2018-10-02 17:55:11
【问题描述】:

尝试从 r 连接到 MySQL:

library(RMySQL)
mydb<-dbConnect(MySQL(), user='root', password='123', dbname='mydb', host='localhost')

得到以下错误:

Error in .local(drv, ...) : Failed to connect to database: 
Error: Can't initialize character set unknown (path: compiled_in)

使用

R ver is 3.3.3
MySQL is '8.0.12'
default_character_set_name in MySQL is utf8mb4

【问题讨论】:

标签: mysql r


【解决方案1】:

我在安装 MySQL 8.0.19 时遇到了同样的问题 解决方案是找到并打开您的 my.cnf 并为 mysql 服务器设置字符集。

character-set-client-handshake = FALSE
character-set-server = utf8mb4
collation-server = utf8mb4_unicode_ci

【讨论】:

    猜你喜欢
    • 2017-09-07
    • 2019-12-12
    • 2017-10-14
    • 1970-01-01
    • 1970-01-01
    • 2013-09-18
    • 2020-11-03
    • 1970-01-01
    • 1970-01-01
    相关资源
    最近更新 更多