【问题标题】:mod_wsgi.so: Cannot load mod_wsgi.so into server: libpython2.5.so.1.0: cannot open shared object file: No such file or directorymod_wsgi.so:无法将 mod_wsgi.so 加载到服务器中:libpython2.5.so.1.0:无法打开共享对象文件:没有这样的文件或目录
【发布时间】:2012-08-30 13:20:13
【问题描述】:

当我输入时:

[root@lts5 /]# ldd /usr/lib64/httpd/modules/mod_wsgi.so
    libpython2.5.so.1.0 => /root/epd-5.1.0/lib/libpython2.5.so.1.0 (0x00002b4b53ccf000)
    libpthread.so.0 => /lib64/libpthread.so.0 (0x00002b4b54036000)
    libdl.so.2 => /lib64/libdl.so.2 (0x00002b4b54251000)
    libutil.so.1 => /lib64/libutil.so.1 (0x00002b4b54456000)
    libc.so.6 => /lib64/libc.so.6 (0x00002b4b54659000)
    libm.so.6 => /lib64/libm.so.6 (0x00002b4b549b1000)
    /lib64/ld-linux-x86-64.so.2 (0x0000003d9f600000)

当我输入时,我怎样才能做到这一点:

[root@lts5srv1 /]# ldd mod_wsgi.so
ldd: ./mod_wsgi.so: No such file or directory

..显示相同的结果?

实际上当我尝试重新启动服务器时:

[root@lts5srv1 mod_wsgi-2.3]# service httpd restart
Stopping httpd:                                            [FAILED]
Starting httpd: httpd: Syntax error on line 202 of /etc/httpd/conf/httpd.conf: 
Cannot load /etc/httpd/modules/mod_wsgi.so into server: 
libpython2.5.so.1.0: cannot open shared object file: No such file or directory
                                                           [FAILED]

【问题讨论】:

    标签: apache mod-wsgi


    【解决方案1】:
    1. 在/etc/ld.so.conf 文件的第一行添加以下内容:

      /usr/local/lib
      include ld.so.conf.d/*.conf
      
    2. 运行ldconfig

    【讨论】:

      【解决方案2】:

      仅当您与 mod_wsgi.so 文件位于同一目录中时,运行“ldd mod_wsgi.so”才有效。

      解释你为什么使用这么旧的 mod_wsgi 版本。您是自己从源代码编译 mod_wsgi 还是使用 mod_wsgi 的现有二进制文件?

      如果从源代码编译,使用mod_wsgi 3.4(最新),当你从源代码编译时,这样做:

      LD_RUN_PATH=/root/epd-5.1.0/lib make
      

      LD_RUN_PATH 会将 Python 库目录的位置嵌入到 mod_wsgi.so 中,因此它可以在运行时找到它,前提是您的库不在标准位置。

      【讨论】:

        猜你喜欢
        • 2014-01-17
        • 2022-09-27
        • 1970-01-01
        • 2019-10-22
        • 2021-06-04
        • 2020-11-06
        • 2021-07-19
        • 2021-12-20
        • 2012-07-13
        相关资源
        最近更新 更多