【发布时间】:2018-01-12 22:17:52
【问题描述】:
我的问题是是否可以将 KnexJS 的字符编码更改为 utf8mb4。它似乎默认为 utf8。
当我尝试在 NodeJS 服务器上的当前 KnexJS 版本上创建表时,通过
db.schema.createTable('testtable', table => {
table.increments('id');
table.string('foo').unique();
});
KnexJS 抛出一个错误,说指定的键太长。这是因为 KnexJS 的 varchar 长度默认为 255。utf8mb4 字段的最大长度为 191 个字符。
是否有一个选项可以告诉 KnexJS 使用什么字符编码(从而将 varchar 字段的长度更改为 191),或者我是否必须自己将每个 varchar 字段的长度设置为 191,方法是将其作为第二个参数传递给 @ 987654322@?
错误信息:
Error creating testtable table { Error: Specified key was too long; max key length is 767 bytes
at Packet.asError (C:\Users\nicoe\WebstormProjects\worktrackr\backend\node_modules\mysql2\lib\packets\packet.js:713:13)
at Query.Command.execute (C:\Users\nicoe\WebstormProjects\worktrackr\backend\node_modules\mysql2\lib\commands\command.js:28:22)
at Connection.handlePacket (C:\Users\nicoe\WebstormProjects\worktrackr\backend\node_modules\mysql2\lib\connection.js:515:28)
at PacketParser.onPacket (C:\Users\nicoe\WebstormProjects\worktrackr\backend\node_modules\mysql2\lib\connection.js:94:16)
at PacketParser.executeStart (C:\Users\nicoe\WebstormProjects\worktrackr\backend\node_modules\mysql2\lib\packet_parser.js:77:14)
at Socket.<anonymous> (C:\Users\nicoe\WebstormProjects\worktrackr\backend\node_modules\mysql2\lib\connection.js:102:29)
at Socket.emit (events.js:159:13)
at addChunk (_stream_readable.js:265:12)
at readableAddChunk (_stream_readable.js:252:11)
at Socket.Readable.push (_stream_readable.js:209:10)
at TCP.onread (net.js:598:20)
code: 'ER_TOO_LONG_KEY',
errno: 1071,
sqlState: '42000',
sqlMessage: 'Specified key was too long; max key length is 767 bytes' }
【问题讨论】:
-
你有没有想过这个问题?我认为使 255 成为有效值的正确解决方案是在执行迁移时更改 knex 的底层编码方案,但我不知道该怎么做。