【发布时间】:2015-02-14 10:03:57
【问题描述】:
在 Ubuntu 上,当我尝试重新启动我的 Nginx 时,我得到了一些错误,但它们没有写入我的 error_log 指令,但仍然写入默认的 /var/log/nginx/error.log 我的 nginx.conf 看起来像这样:
server {
listen 80;
charset utf-8
error_log /home/ubuntu/nginxerror.log;
location / {
uwsgi_pass django;
include /etc/nginx/uwsgi_params;
}
}
我其实对此有一些想法,如果你注意,你应该会看到我忘记了“;”在“charset utf-8”之后,这就是nginx启动失败的原因,我猜是因为语法不正确,nginx配置没有成功加载,所有错误都进入默认日志。
有谁知道为什么。
【问题讨论】:
-
那么问题是什么?
-
我只是确认我的假设是正确的“由于语法不正确,nginx config 没有成功加载,所有错误都进入默认日志。”,是吗?