【问题标题】:Nginx error is not written to my error_log directiveNginx 错误未写入我的 error_log 指令
【发布时间】:2015-02-14 10:03:57
【问题描述】:

在 Ubuntu 上,当我尝试重新启动我的 Nginx 时,我得到了一些错误,但它们没有写入我的 error_log 指令,但仍然写入默认的 /var/log/nginx/error.log 我的 nginx.conf 看起来像这样:

server {
    listen      80;
    charset     utf-8

    error_log /home/ubuntu/nginxerror.log;

    location / {
        uwsgi_pass  django;
        include     /etc/nginx/uwsgi_params;
        }
    }

我其实对此有一些想法,如果你注意,你应该会看到我忘记了“;”在“charset utf-8”之后,这就是nginx启动失败的原因,我猜是因为语法不正确,nginx配置没有成功加载,所有错误都进入默认日志。

有谁知道为什么。

【问题讨论】:

  • 那么问题是什么?
  • 我只是确认我的假设是正确的“由于语法不正确,nginx config 没有成功加载,所有错误都进入默认日志。”,是吗?

标签: ubuntu nginx


【解决方案1】:

检查您的 nginx 配置是否使用以下命令的最简单方法: $ nginx -c /etc/nginx/nginx.conf -t

您的站点配置和 nginx.conf 文件本身的错误根据您的配置 http 部分中的 error_log 指令 (docs) 进行记录,默认情况下为 /var/log/nginx/error.log。

【讨论】:

    猜你喜欢
    • 2011-12-12
    • 1970-01-01
    • 2011-11-21
    • 2015-04-11
    • 2010-11-23
    • 2014-06-10
    • 2011-09-21
    • 1970-01-01
    • 1970-01-01
    相关资源
    最近更新 更多