【问题标题】:503 Server Error with new Flexible Environment App新的柔性环境应用程序出现 503 服务器错误
【发布时间】:2016-11-09 12:34:30
【问题描述】:

创建了一个新的灵活环境应用程序并使用最新的 GCloud 版本(当前为 133)成功部署,但得到“503 服务器错误”而没有任何错误日志。

源码:https://github.com/AIMMOTH/scala-stack-angular/tree/503-error

应用链接:https://scala-stack-angular-us.appspot.com

Error page:
Error: Server Error

The service you requested is not available yet.
Please try again in 30 seconds.

版本信息:

Version Status  Traffic Allocation  Instances   Runtime Environment Size    Deployed    Diagnose

20161108t190158     Serving     100 %    2  custom  Flexible

【问题讨论】:

  • 我也面临同样的问题:\

标签: google-app-engine gcloud


【解决方案1】:

我有一个过滤器响应 /_ah/* 并破坏了 Google App Engine。

【讨论】:

    【解决方案2】:

    对我来说,这是因为app.yaml中的设置错误:

    vm: true                                # the flexible environment
    runtime: java                           # Java 8 / Jetty 9.3 Runtime
    service: default
    threadsafe: true                        # handle multiple requests simultaneously
    
    resources:
      cpu: .5                               # number of cores
      memory_gb: 1.3
      disk_size_gb: 10                      # minimum is 10GB and maximum is 10240GB
    
    health_check:
      enable_health_check: true
      check_interval_sec: 5                 # time interval between checks (in seconds)
      timeout_sec: 4                        # health check timeout interval (in seconds)
      unhealthy_threshold: 2                # an instance is unhealthy after failing this number of consecutive checks
      healthy_threshold: 2                  # an unhealthy instance becomes healthy again after successfully responding to this number of consecutive checks
      restart_threshold: 60                 # the number of consecutive check failures that will trigger a VM restart
    
    automatic_scaling:
      min_num_instances: 1
      max_num_instances: 1
      cool_down_period_sec: 120             # time interval between auto scaling checks. It must be greater than or equal to 60 seconds.
                                            # The default is 120 seconds
      cpu_utilization:
        target_utilization: 0.5             # CPU use is averaged across all running instances and is used to decide when to reduce or
                                            # increase the number of instances (default 0.5)
    
    handlers:
    - url: /.*                              # regex
      script: ignored                       # required, but ignored
      secure: always                        # https
    
    
    beta_settings:
      java_quickstart: true                 # process Servlet 3.1 annotations
      use_endpoints_api_management: true    # enable Google Cloud Endpoints API management
    

    我删除了use_endpoints_api_management: true,一切正常。

    【讨论】:

      猜你喜欢
      • 2023-03-15
      • 2021-04-12
      • 1970-01-01
      • 1970-01-01
      • 1970-01-01
      • 2021-07-30
      • 1970-01-01
      • 1970-01-01
      • 2012-11-07
      相关资源
      最近更新 更多