【问题标题】:Nginx + Docker Compose - connect() failed (111: Connection refused) while connecting to upstreamNginx + Docker Compose - 连接到上游时连接()失败(111:连接被拒绝)
【发布时间】:2020-04-03 03:17:01
【问题描述】:

感谢您花时间阅读本文。我正在尝试使用 docker-compose 将我的应用程序部署到 AWS EC2 实例。当我运行命令docker-compose up 并访问该站点时,我从 nginx 收到一个错误,提示以下错误。我了解 nginx 正在接收请求,但无法找到与我的 react 应用程序的上游连接,如果在正确配置端口/设置方面提供任何帮助,我将不胜感激。

错误

2 connect() failed (111: Connection refused) while connecting to upstream, client: 108.212.77.70 server: example.com, request: "GET / HTTP/1.1", upstream: "http://172.29.0.4:8003/", host: "example.com"

这是我的 nginx 默认配置

upstream meetup_ws {
    server channels:8001;
}

upstream meetup_backend {
    server backend:8000;
}

upstream meetup_frontend {
    server frontend:8003;
}

server {
    listen 0.0.0.0:80;
    server_name example.com www.example.com;
    return 301 https://$server_name$request_uri;
}

server {
    listen 443 ssl;
    listen [::]:443 ssl;
    server_name example.com example.com;
    root /var/www/frontend;
    index index.html;
    ssl_certificate /etc/nginx/certs/fullchain.pem;
    ssl_certificate_key /etc/nginx/certs/privkey.pem;
    add_header Strict-Transport-Security "max-age=31536000";

    location / {
        proxy_set_header Host $host;
        proxy_set_header X-Real-IP $remote_addr;
        proxy_set_header X-Forwarded-Proto https;
        proxy_set_header X-Forwarded-Host $host;
        proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
        proxy_pass http://meetup_frontend;
    }

    location /api {
        try_files $uri @proxy_api;
    }

    location @proxy_api {
        proxy_set_header Host $host;
        proxy_set_header X-Real-IP $remote_addr;
        proxy_set_header X-Forwarded-Proto https;
        proxy_set_header X-Forwarded-Host $host;
        proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
        proxy_pass http://meetup_backend;
    }

    location /ws {
        try_files $uri @proxy_websocket;
    }

    location @proxy_websocket {
        proxy_set_header Host $host;
        proxy_set_header X-Real-IP $remote_addr;
        proxy_set_header X-Forwarded-Proto https;
        proxy_set_header X-Forwarded-Host $host;
        proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
        proxy_pass http://meetup_ws;
    }
}

这是我的 docker-compose.yml

version: '3'

services: 
    nginx:
        build: ./nginx
        restart: always
        ports:
            - 80:80
            - 443:443
        volumes:
            - ./nginx/default.conf:/etc/nginx/conf.d/default.conf
            - ./frontend/build:/var/www/frontend
            - ./nginx/certs:/etc/nginx/certs
        depends_on: 
            - channels
    db:
        image: postgres:12.0-alpine
        ports: 
            - 5432:5432
        environment: 
            - POSTGRES_USER=postgres
            - POSTGRES_HOST=db
            - POSTGRES_PASSWORD=password
        volumes:
            - postgres_data:/var/lib/postgresql/data/
    backend: &backend
        build: ./backend
        volumes: 
            - ./backend:/app
        ports: 
            - 8000:8000
        command: ["python", "manage.py", "runserver"]
        env_file:
            - ./.env
        depends_on: 
            - db
            - redis
    frontend:
        build: ./frontend
        volumes: 
            - ./frontend:/app
            - node_modules:/app/node_modules
        ports: 
            - 8003:8003
        command: npm start
        stdin_open: true
    redis:
        image: "redis:5.0.7"
    worker_channels:
        <<: *backend
        command: ["python", "manage.py", "runworker", "channels"]
        depends_on:
            - db
            - redis
        ports:
            - 8002:8002
    channels:
        <<: *backend
        command: daphne -b 0.0.0.0 -p 8001 backend.asgi:application
        ports: 
            - 8001:8001
        depends_on:
            - db
            - redis

volumes:
    node_modules:
    postgres_data:

【问题讨论】:

  • frontend 容器真的在运行吗?您在部署环境中谈论这个,但也使用volumes: 覆盖图像中的代码;您是否还手动将应用程序代码复制到目标服务器?您的 volumes: 正在指示 Docker 使用任意旧的 node_modules 树而不更新它;这会造成麻烦吗?
  • 感谢大卫的回复。前端容器正在运行,并且前端容器中的 react 应用程序已成功编译。我不确定我是否完全理解了这个问题,但我认为 node_modules 不会造成麻烦,因为这是我第一次在 ec2 服务器上使用最新的 package.json 运行 npm install。

标签: docker nginx docker-compose


【解决方案1】:

为什么存在问题有点尴尬,但我能够解决问题。我做了 ping frontend 在我的 nginx 容器中,它成功地 ping 了前端容器。接下来我做了curl -L http://frontend:8003,它说curl: (7) Failed to connect to frontend port 8003: Connection refused。我去了前端容器并做了netstat -tulpn,它将3000列为暴露的端口。我检查了我的 .env 文件,它缺少端口 = 8003。 Nginx 之后能够连接上游。

【讨论】:

    猜你喜欢
    • 2014-02-26
    • 2012-11-21
    • 2020-07-29
    • 2020-03-13
    • 1970-01-01
    • 2013-11-03
    • 2019-12-02
    • 1970-01-01
    • 1970-01-01
    相关资源
    最近更新 更多