【问题标题】:Debian 7 64bit Squid3 Server Won't StartDebian 7 64 位 Squid3 服务器无法启动
【发布时间】:2014-06-27 12:35:03
【问题描述】:

我在运行 squid3 时遇到了问题。我之前成功设置了squid3代理服务器,这是第一次遇到这个错误。基本上每当我尝试启动 squid3 时,我都会得到

[....] 启动 Squid HTTP Proxy 3.x: squid3/etc/init.d/squid3: line 72: cd: HOME not set .好的

它什么也没做。我不太确定这意味着什么,我所做的谷歌搜索也没有发现任何东西。

【问题讨论】:

    标签: proxy debian squid


    【解决方案1】:

    /etc/init.d/squid3 中有一个 find_cache_dir 解析 /etc/squid3/squid.conf 以尝试查找 cache_dir 指令的值。

    如果缓存目录被注释,find_cache_dir 什么也不返回。

    然后 cd $cache_dir 返回 "cd: HOME not set" 但它会在我的设置中启动 squid。

    取消注释 /etc/squid3/squid.conf 中的 cache_dir 停止显示此错误。

    【讨论】:

      猜你喜欢
      • 2012-08-31
      • 1970-01-01
      • 2011-12-08
      • 1970-01-01
      • 1970-01-01
      • 1970-01-01
      • 2013-08-03
      • 1970-01-01
      • 1970-01-01
      相关资源
      最近更新 更多