【问题标题】:How to start php7.3-fpm on Debian 10.3? Error: Failed to start The PHP 7.3 FastCGI Process Manager如何在 Debian 10.3 上启动 php7.3-fpm?错误:无法启动 PHP 7.3 FastCGI 进程管理器
【发布时间】:2020-03-10 15:24:03
【问题描述】:

在全新安装 Debian 10.3 时,我尝试安装 php-fpm,但无法正确配置。

$ sudo apt install php-fpm

抛出这个:

(...)   
Detected unsafe path transition / → /run during canonicalization of /run.
Job for php7.3-fpm.service failed because the control process exited with error code.
See "systemctl status php7.3-fpm.service" and "journalctl -xe" for details.
invoke-rc.d: initscript php7.3-fpm, action "start" failed.
● php7.3-fpm.service - The PHP 7.3 FastCGI Process Manager
   Loaded: loaded (/lib/systemd/system/php7.3-fpm.service; enabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since Tue 2020-03-10 12:03:31 -03; 6ms ago
     Docs: man:php-fpm7.3(8)
  Process: 7111 ExecStart=/usr/sbin/php-fpm7.3 --nodaemonize --fpm-config /etc/php/7.3/fpm/php-fpm.conf (code=exited, status=78)
 Main PID: 7111 (code=exited, status=78)
 (...)

它还抱怨 libapache2-mod-php7.3 依赖项,但我不想使用 Apache。

【问题讨论】:

    标签: php debian


    【解决方案1】:

    只需在/var/run中为php创建一个文件夹

    sudo mkdir /var/run/php
    sudo apt install --reinstall php-fpm
    

    【讨论】:

    • 安装 iRedMail 并重启服务器后。不要启动php fpm。由mkdir /var/run/php修复的项目
    猜你喜欢
    • 2020-10-17
    • 2012-11-12
    • 1970-01-01
    • 1970-01-01
    • 2019-02-18
    • 2014-05-13
    • 1970-01-01
    • 1970-01-01
    • 2016-02-01
    相关资源
    最近更新 更多