【问题标题】:Debian Linux: Start Nginx at rebooting machineDebian Linux:在重启机器时启动 Nginx
【发布时间】:2013-04-30 12:35:02
【问题描述】:

我正在使用 Debian linux。我试图让 Nginx 服务器在重启时自动启动。顺便说一句,我可以像

一样启动和停止 nginx
$ /etc/init.d/nginx start
$ /etc/init.d/nginx stop

我用谷歌搜索发现必须将脚本添加到 update-rc.d 所以我这样做了

$ /usr/sbin/update-rc.d -f nginx defaults

但是当我重新启动 nginx 时,我的站点无法启动,我的站点出现了错误的网关!

请提前

【问题讨论】:

  • 错误日志中有什么内容?

标签: nginx debian


【解决方案1】:

您需要检查正在运行的进程和 nginx 日志文件以确定问题的原因。 例如,“Bad gateway”可能意味着 nginx 实际上已启动,但 PHP5 后端(例如 php5-fpm)没有运行。

【讨论】:

    猜你喜欢
    • 1970-01-01
    • 1970-01-01
    • 2015-01-25
    • 2016-11-14
    • 1970-01-01
    • 1970-01-01
    • 1970-01-01
    • 2019-08-23
    • 1970-01-01
    相关资源
    最近更新 更多