【问题标题】:SSIS Execute Process Task fails with SQL agentSSIS 执行进程任务因 SQL 代理而失败
【发布时间】:2018-10-19 17:08:54
【问题描述】:

我有一个 SSIS 包,其中包含一个运行 exe 的执行进程任务。所有代码和可执行文件都位于同一台服务器上。 SSIS 包在项目内部运行,但在我上传到 SSIS 并通过 SQL Server 代理运行时不运行。不确定为什么它不会在代理中运行。 Exe 和包本身运行良好,但在 Agent 中却不行。感谢任何帮助。以下是我收到的错误:

Microsoft (R) SQL Server 执行包实用程序版本 10.50.6000.34 对于 32 位版权所有 (C) Microsoft Corporation 2010。所有权利 保留。

开始时间:晚上 10:57:20 错误:2018-10-19 10:57:43.83 代码: 0xC0029151 来源:下载XLS执行进程任务
说明:在执行“F:\Data Imports\Office_Codes_monthly_download\EXE\PullOffices.exe" "" at "F:\Data Imports\Office_Codes_monthly_download\EXE", 进程退出 代码为“255”,而预期为“0”。结束错误 DTExec: 包执行返回 DTSER_FAILURE (1)。开始时间:晚上 10:57:20 完成时间:晚上 10:57:43 已用时间:23.042 秒

【问题讨论】:

  • 可执行文件是否在 SQL Server 的那个位置?运行 SQL 代理作业的用户(很可能是服务帐户)是否有权访问位置和运行可执行文件的权限?
  • 也许权限?运行代理的帐户或使用代理帐户是否可以访问 exe?
  • 是的,exe 与 SQL 服务器位于同一服务器上的该位置。我仔细检查了服务帐户,它是对文件夹和所有内容拥有完全权限的管理员。不使用代理。额外说明.... exe 将半运行。因为它将开始替换我的文件但未完成。所以文件将有 0kb 并且不会打开。但如果我自己运行 exe,文件将完全被替换和打开。
  • PullOffices.exe 在做什么?
  • 它从网站下载 xls 文件并将其保存到服务器上的某个位置

标签: sql-server ssis sql-server-job


【解决方案1】:

尝试将证书信息与 FTPES 命令一起传递,如下所示。

open ftpes://FTPDDRIV:dr2pfile@dvlp.mvs.us.ups.com -explicit -certificate=xx:71:xx:xx:a2:eb:23:xx:xx:eb:xx:x:xx:xx:5d:74:4d:c2:c6:37
put D:\UPSdata\UPSDrive\Integration\document.txt
exit

【讨论】:

    猜你喜欢
    • 2017-09-08
    • 1970-01-01
    • 1970-01-01
    • 1970-01-01
    • 1970-01-01
    • 1970-01-01
    • 1970-01-01
    • 1970-01-01
    • 1970-01-01
    相关资源
    最近更新 更多