【问题标题】:OpenSQLServerInstanceRegKey:GetRegKeyAccessMask failed (reason: 2)OpenSQLServerInstanceRegKey:GetRegKeyAccessMask 失败(原因:2)
【发布时间】:2014-09-18 15:39:42
【问题描述】:

使用 SQL Server 2012 我的 Windows Server 2012 R2 出现以下错误

OpenSQLServerInstanceRegKey:GetRegKeyAccessMask 失败(原因:2)。

【问题讨论】:

  • 我遇到了同样的问题...我使用的是 Microsoft SQL SERVER express edition 2012。如果我必须安装任何服务包,请告诉我
  • 请给出更具体的错误,您打算使用 sql server 代理吗?这个错误是什么时候发生的?

标签: sql-server


【解决方案1】:

我找到了答案 - SQLServer Express 版不支持 SQL Server 代理。

【讨论】:

    【解决方案2】:

    尝试启动 SQL 代理时,我在本地工作站的应用程序日志中遇到了同样的错误。

    SQLAGENT.OUT 文件在前面的答案中提到的日志路径中不存在。我想知道代理的服务帐户是否缺少访问此日志文件夹的权限...

    我尝试将服务帐户“NT Service...”添加到该文件夹​​的已批准用户列表中。不高兴 - 无法在工作站的用户列表中看到该帐户。

    所以,我更改了 SQL Agent 的服务帐户以匹配 SQL Server 服务的服务帐户。答对了!代理启动,SQLAGENT.OUT 文件出现在日志文件夹中。

    不必太担心让引擎和代理的服务帐户相同的任何安全隐患,因为它是我的本地开发工作站...

    【讨论】:

      【解决方案3】:

      您需要从日志目录中删除 SQLAGENT.OUT 日志文件(您的可能略有不同):

      C:\Program Files\Microsoft SQL Server\MSSQL11.MSSQLSERVER\MSSQL\Log\SQLAGENT.OUT

      这是 SQL Server 2012 SP1 中修复的一个已知问题,但我没有时间搞砸数据库升级,所以我应用了上述解决方法,并且能够成功启动 SQL 代理。

      点击here了解更多信息。

      【讨论】:

      • 对我不起作用。删除日志文件后仍然无法启动。
      【解决方案4】:

      我重启电脑3次,

      发现虽然无法启动Server Agent, 奇怪的是,我可以在 SQL 管理工作室中连接到我的数据库...

      数据库可以连接和使用是我关心的, 所以我没有让 mopre 尝试启动 SQL Server 代理。

      【讨论】:

        猜你喜欢
        • 2013-06-26
        • 2021-11-30
        • 1970-01-01
        • 2013-12-22
        • 1970-01-01
        • 2018-08-30
        • 2016-03-08
        • 1970-01-01
        • 1970-01-01
        相关资源
        最近更新 更多