【问题标题】:WampServer Apache httpd.exe application was unable to start correctly (0xc0000142) after Windows 10 Creators Update (1703))WampServer Apache httpd.exe 应用程序在 Windows 10 Creators Update (1703) 后无法正确启动 (0xc0000142)
【发布时间】:2017-05-10 19:17:23
【问题描述】:

Windows 10 Creators 更新似乎破坏了 Apache 的 httpd 服务,现在我第一次启动 WampServer 时会出错。

官方表格confirms这个怀疑。

WampServer 版本 3.0.6。

但是,截至本文发布时,论坛上的建议解决方案均未奏效。因此,我提出了这个问题,以便我们社区成员可以在这里找到解决方案。

请注意,降级 Windows 不是一个可行的解决方案。

【问题讨论】:

  • 请注意,在错误消息上单击“确定”后,服务会显示为启动,该问题影响了某些功能 - 例如使用 exec() 和 popen() 等命令的能力。
  • 仅供参考 - 一个非常相似的问题 stackoverflow.com/questions/14522171/… 已作为题外话关闭
  • 天啊,我多么讨厌严厉的微软!我回来了,我的机器重新启动,出现这种类型的错误...没有保存文件,对系统的更新我没有批准。是时候回到 Ubuntu...

标签: apache wamp wampserver


【解决方案1】:

更新:看起来 3.0.8 补丁解决了 WampServer 3.0.6 和 Windows 10 创意者更新的问题。

在网站上没有很好地宣传,(您需要单击网站上的 SourceForge 链接并导航文件夹结构才能找到它。)此处直接链接到更新:

https://sourceforge.net/projects/wampserver/files/WampServer%203/WampServer%203.0.0/Updates/wampserver3_x86_x64_update3.0.9.exe/download

更新:看起来 3.0.8 已经下架了,因为 3.0.9 刚出来;这是 3.0.9 的链接: https://downloads.sourceforge.net/project/wampserver/WampServer%203/WampServer%203.0.0/Updates/wampserver3_x86_x64_update3.0.9.exe?r=https%3A%2F%2Fsourceforge.net%2Fprojects%2Fwampserver%2Ffiles%2FWampServer%25203%2FWampServer%25203.0.0%2FUpdates%2F&ts=1498418727&use_mirror=pilotfiber

【讨论】:

  • 也为我工作。仅供参考,如果您正在安装,请选择相同的目录(我的是C:\\wamp64,而不是C:\\wamp,默认)。
  • 链接已修复,指向替换 3.0.8 的 3.0.9 更新。
猜你喜欢
  • 2017-10-21
  • 1970-01-01
  • 2011-09-20
  • 1970-01-01
  • 1970-01-01
  • 1970-01-01
  • 2016-05-18
  • 1970-01-01
  • 2017-08-29
相关资源
最近更新 更多