【问题标题】:"AllowOverride not allowed here" in WAMPWAMP中的“此处不允许AllowOverride”
【发布时间】:2013-10-13 02:24:10
【问题描述】:

我已启用 mod_rewrite(已在我的任务栏中的 WAMP 图标中选中,并在 httpd.conf 中取消注释)并且我已确保 httpd.conf 中的任何 AllowOverride 设置都设置为 All,但我我仍然收到500 错误消息和

[alert] [client 127.0.0.1] E:/mywebsite/html/.htaccess: AllowOverride not allowed here

在我的 Apache 错误日志中。

这可能是因为将 DocumentRoot 更改为完全不同的结果吗?我在D:\ 上安装了WAMP,并将根目录更改为E:\ 上的我的Dropbox 文件夹。

WAMP 是否有一个额外的 conf 文件可以像 XAMPP 一样设置特殊设置?

为什么我仍然收到此错误?我已经在互联网上搜索了很多答案,但他们都告诉我启用该模块并且我已经完成了。

在 Windows 7 上,WAMP 2.2。

【问题讨论】:

  • 您在E:/mywebsite/html/.htaccess 中似乎有一个AllowOverride 行
  • 我读到您需要在您的.htaccess 文件中包含AllowOverride,但似乎不需要。干杯!

标签: apache .htaccess mod-rewrite wamp


【解决方案1】:

只是将我的评论作为答案,因为它似乎已经解决了 OP 的问题。

查看错误,E:/mywebsite/html/.htaccess 中似乎有一个 AllowOverride 行,而 Apache 抛出 500 错误,因为在 .htaccess 中不允许使用 AllowOverride。

【讨论】:

    猜你喜欢
    • 1970-01-01
    • 1970-01-01
    • 1970-01-01
    • 2020-03-31
    • 2011-10-29
    • 2015-07-16
    • 2021-11-07
    • 2013-04-15
    • 1970-01-01
    相关资源
    最近更新 更多