【问题标题】:mysqld working but wampmysqld not starting upmysql工作但wamp mysql没有启动
【发布时间】:2013-07-21 09:24:24
【问题描述】:

从这里跟进:Wampserver icon not going green fully, mysql services not starting up?

我可以看到mysqld 现在正在工作。但是wampmysqld 仍然不能作为服务工作!

d:\wamp\bin\mysql\mysql5.5.8\bin>mysqld.exe --console
130721 12:10:45 [Note] Plugin 'FEDERATED' is disabled.
InnoDB: The InnoDB memory heap is disabled
InnoDB: Mutexes and rw_locks use Windows interlocked functions
InnoDB: Compressed tables use zlib 1.2.3
130721 12:10:45  InnoDB: Initializing buffer pool, size = 128.0M
130721 12:10:45  InnoDB: Completed initialization of buffer pool
130721 12:10:45  InnoDB: highest supported file format is Barracuda.
130721 12:10:45  InnoDB: 1.1.4 started; log sequence number 1595675
130721 12:10:45 [Note] Event Scheduler: Loaded 0 events
130721 12:10:45 [Note] mysqld.exe: ready for connections.
Version: '5.5.8'  socket: ''  port: 3306  MySQL Community Server (GPL)

我已经删除了 mysql /data/ 文件夹中的所有文件,当我运行 mysqld 时,创建了一个新的 ibdata1 文件。所以处理 InnoDB 文件似乎很好。但是 wampmysqld 还是给了Error 1067。

这些是 wampserver 生成的 mysql 错误日志的最后几行:

130720 10:28:45 [Note] Event Scheduler: Purging the queue. 0 events
130720 10:28:46  InnoDB: Starting shutdown...
130720 10:28:52  InnoDB: Shutdown completed; log sequence number 29711976
130720 10:28:52 [Note] wampmysqld: Shutdown complete

这意味着它昨天早上十点半左右关闭了,之后就没有启动了!

【问题讨论】:

    标签: mysql wampserver


    【解决方案1】:

    这对我有用:http://jinengbali.wordpress.com/2010/04/20/mysql-server-stop-working-in-wampserver-error-wampmysqld-shutdown-complete/

    我安装了一个“插件”,然后从 wampserver 图标中选择 > MySQL > 版本并选择一个新安装的版本。图标终于变绿了!

    【讨论】:

      【解决方案2】:

      实际上它不应该工作。 显然您已将一些数据库文件硬拷贝到“数据”文件夹中。 只是让你知道,mysql 不喜欢这样的东西,永远不会启动。试想一下,出于安全原因,有人将文件添加到您的服务器。可能您在服务器已经启动并且预计不会出现问题时添加了这些文件。

      你可以做两件事:

      1. 在Linux上删除索引文件mysql-bin.index(我不知道Windows对应的文件)。
      2. 您应该简单地从“数据”文件夹中删除添加的文件,然后它会变成绿色。

      规则:尝试通过 csv 导入选项添加数据库,但切勿手动将它们添加为文件夹。

      【讨论】:

        【解决方案3】:

        我遇到了同样的问题,解决方法是:

        转到服务,(在运行中键入命令services.msc)找到安装在wamp之外的mysql服务,右键单击它并停止。 然后再次在服务面板中转到 wampmysqld64-> 右键单击​​-> 开始

        如果你只需要wamp的mysql版本,那么你可以关闭其他mysql服务。

        它解决了我的问题。希望这会有所帮助!

        【讨论】:

          【解决方案4】:

          在您的计算机中重新安装整个 wampserver,wampmysqld 文件将由系统分配回来。就这么简单。

          【讨论】:

            【解决方案5】:

            我遇到了类似的问题去mysql打开日志文件应该可以找到错误的原因。

            1.在我的情况下,日志文件不存在,所以我创建了一个新文件。

            2.在另一种情况下,您的日志文件可能会出现读取错误,因此在这种情况下可能会导致错误,只需找到并删除有问题的文件,即文件“C:\wamp\logs”的路径。完成尝试从 wamp 面板打开 sql 日志。

            3.如果您尝试了上述所有方法,但都没有结果,请尝试在日志文件中查找可能出现错误的原因并在 Google 上搜索。

            【讨论】:

              【解决方案6】:

              我遇到了同样的错误。我如何解决它是端口号。分配给wampmysql的是3306,它被另一个服务使用,所以右键单击wamp图标->工具->使用3306以外的端口(在mysql使用的端口下)->更改端口号。说 3310-> 按回车键。图标变为绿色并开始工作。 希望对您有所帮助。

              【讨论】:

              • 甚至比更改端口号更好。因为它给出的数据库错误是在 services.msc (windows+r) 中的同一端口上停止服务,在我的情况下是 mySql57
              猜你喜欢
              • 2017-03-25
              • 2016-08-15
              • 2021-07-29
              • 2014-08-08
              • 2016-03-14
              • 1970-01-01
              • 1970-01-01
              • 2015-09-15
              • 2017-05-30
              相关资源
              最近更新 更多