【问题标题】:After hosting to server symfony gives 500 internal server error托管到服务器后 symfony 给出 500 内部服务器错误
【发布时间】:2017-04-28 18:20:35
【问题描述】:

我的项目上线后,什么都没有出现,出现空白页或者报错HTTP ERROR 500..

我不知道该怎么办,如果有人会帮忙请..

我已经做了以下事情:

composer install
asset:install

我会尽快回复您的回答

【问题讨论】:

  • 您使用的是什么版本的 PHP 和 Symfony?日志中是否有任何内容,也许? :)
  • Symfony 3 和 PHP 5.5.12

标签: symfony ftp upload


【解决方案1】:

我已经在使用 Symfony 3 时遇到了同样的问题,解决方案在 app.php 中:

在我的例子中是因为 bootstrap.php.cache 没有显示出来。

在你的文件中评论这部分:

include_once __DIR__.'/../var/bootstrap.php.cache';

另外,我不明白为什么。

【讨论】:

  • 哇!!!你说的对 !我不明白为什么会这样,但评论这一行是有效的:D
  • 我认为这是有原因的,但我仍在寻找解决这个问题的正确答案^^
【解决方案2】:

如果项目使用 php 语言完成并且您将文件上传到服务器。

有时文件和文件夹权限会出现此错误。

请查看文件权限为644,文件夹权限为755。

【讨论】:

  • 好吧,如果我理解正确的话,所有文件夹都必须有755权限,文件必须有644权限?
  • 是的,您可以将其作为解决此问题的第一步。
【解决方案3】:

我遇到了同样的问题。您必须对 Symfony 的缓存目录进行 chmod。

【讨论】:

  • 我将权限设置为 777 但没有
【解决方案4】:

好的,如果您检查了所有以前的答案建议,并且一切正常,那么我可以考虑以下:

  • 检查您是否在服务器上复制了web/.htaccess 文件。我认为这需要有0644 作为特权。
  • 如果你复制了它,但仍然得到 500,那可能是因为你的源代码有错误,而且,检查是否有任何源代码错误的最简单方法,只需在你的 PC 中编辑,web/app_dev.php 文件,并注释掉这些代码行:

    if (isset($_SERVER['HTTP_CLIENT_IP'])
        || isset($_SERVER['HTTP_X_FORWARDED_FOR'])
        || !(in_array(@$_SERVER['REMOTE_ADDR'], ['127.0.0.1', '::1']) || php_sapi_name() === 'cli-server')
    ) {
        header('HTTP/1.0 403 Forbidden');
        exit('You are not allowed to access this file. Check '.basename(__FILE__).' for more information.');
    }
    

上传到服务器的web目录,然后访问网站首页,dev模式,前面使用/app_dev.php。 这将检查任何错误。

但是要注意,结束这个任务后,需要把app_dev.php文件中的上述几行代码去掉注释,然后重新上传到服务器,作为这个文件的最后一部分代码不应在远程服务器上执行。

【讨论】:

  • 当我评论与上面相同的代码片段时,我去www.domain.com/app_dev.php,它很好地显示了我的页面。当我尝试传递其他页面时,我的查询运行良好。但只有当app_dev.php 出现在 URL 中时
  • 我可以使用app_dev.php 访问我所有的页面和我的应用程序,我只是在网上做一个测试。但在产品中它不起作用
猜你喜欢
  • 2018-05-08
  • 1970-01-01
  • 2014-01-10
  • 2013-08-10
  • 2015-05-07
  • 1970-01-01
  • 1970-01-01
  • 1970-01-01
相关资源
最近更新 更多