【问题标题】:Docker & Wordpress - The uploaded file could not be moved to wp-content/uploads/.../Docker & Wordpress - 上传的文件无法移动到 wp-content/uploads/.../
【发布时间】:2018-11-29 12:04:22
【问题描述】:

错误:

上传的文件无法移动到wp-content/uploads/.../...。

环境:

Wordpress Docker 镜像是从基本的 Wordpress 镜像创建的,然后文件被映射进出,用于开发:

version: '3'

services:
  wordpress:
    restart: always
    environment:
      WORDPRESS_DB_NAME: ...
      WORDPRESS_DB_HOST: ...
      WORDPRESS_DB_USER: ...
      WORDPRESS_DB_PASSWORD: ...

    image: wordpress:latest
    ports:
      - 38991:80
    volumes:
      - ./:/var/www/html

我们与托管在 Docker 容器外部的开发数据库交谈。

图像已构建 - 并发送到服务器。然后,CMS 用户尝试上传图像,Wordpress 构建抱怨上传的文件无法移动到wp-content/uploads/.../...。我们在localhost 上没有收到此错误。

能否请一些 devops 专家指出正确的方向,以便在服务器上进行统计。

【问题讨论】:

    标签: wordpress docker


    【解决方案1】:

    wp-content/uploads 目录的权限不正确。我遇到了同样的错误,在我的情况下,上传文件夹的权限和用户/组设置错误,并且里面的一些文件夹被设置为 root。但这可能是因为我导入了备份。

    要修复上传,您可以将以下两个命令添加到部署管道/脚本或使用 docker exec -it <container-name> bash 在容器上手动执行。

    1. 在上传文件夹中设置正确的用户/组:$ chown -R www-data:www-data uploads/*
    2. 设置正确的权限:$ chmod 755 uploads/*

    【讨论】:

    • 应该是 chown -R www-data:www-data uploads/
    猜你喜欢
    • 2016-02-05
    • 2022-09-23
    • 2013-10-01
    • 2018-02-21
    • 1970-01-01
    • 1970-01-01
    • 2017-10-12
    • 2013-05-07
    • 2014-03-14
    相关资源
    最近更新 更多