【问题标题】:solr dataimport error: Indexing failed. Rolled back all changessolr 数据导入错误:索引失败。回滚所有更改
【发布时间】:2011-11-22 22:12:48
【问题描述】:

当我运行“带有清理的完整导入”命令时,错误是“索引失败。回滚所有更改”

我的数据导入配置文件:

<dataConfig>
  <dataSource type="JdbcDataSource" name="ds-1" driver="com.mysql.jdbc.Driver" url="jdbc:mysql://my.ip/my_db" user="my_db_user" password="my_password" readOnly="True"/>
  <document> 
    <entity name="videos" pk="ID" transformer="TemplateTransformer" dataSource="ds-1" 
            query="SELECT * FROM videos LIMIT 100">
      <field column="id" name="unid" indexed="true" stored="true" />
      <field column="title" name="baslik" indexed="true" stored="true" />
      <field column="video_img" name="img" indexed="true" stored="true" />
    </entity>
  </document>
</dataConfig>

【问题讨论】:

  • 你也可以提供堆栈跟踪吗?
  • 恐怕我们无法真正帮助您,我们需要更多信息

标签: solr lucene dataimporthandler


【解决方案1】:

我在某个时间点不断收到相同的错误消息。对我来说有以下原因:

  • 错误的连接字符串。
  • 错误的驱动程序(com.mysql.jdbc.Driver)
  • 错误查询
  • 列到 solrfields 的错误映射(我认为这也可能是您的问题)

确保数据库中的列名与 SOLR 中的列名相同(区分大小写)。如果不重命名查询中的colmuns名称:

select id as uniqueid, title as Tittle

或在您定义的实体中使用字段元素,如下所示:

<field column="ID" name="id" />

您使用的字段元素错误。请参阅此处如何使用此元素:http://wiki.apache.org/solr/DataImportHandler#Configuration_in_data-config.xml

如果您可以分享其他相关数据和日志,我们可以为您提供更具体的信息。

祝你好运。

【讨论】:

  • 坏驱动(com.mysql.jdbc.Driver)的可能性是真的。谢谢。
猜你喜欢
  • 1970-01-01
  • 1970-01-01
  • 1970-01-01
  • 1970-01-01
  • 1970-01-01
  • 2011-10-02
  • 1970-01-01
  • 1970-01-01
  • 2017-02-16
相关资源
最近更新 更多