【发布时间】:2010-09-14 16:33:00
【问题描述】:
我已经使用负载平衡器 (Apache) 和三个运行 Jboss 4.2.2 的应用程序节点配置了一个粘性会话。 负载均衡器使用这里教程中提到的 mod_jk 和设置。
http://community.jboss.org/wiki/UsingModjk12WithJBoss;jsessionid=1569CBFB7C3096C59C977CD3F7159A32
我将三个节点的 jumRoute 设置为 node1 、 node2 和 node3 ,并且我的负载均衡器的 workerlist 属性设置为 节点1,节点2,节点3
教程一直到最后一点,但我没有配置useJK参数下。该值仍然设置为false。 粘性会话持续存在,但我似乎松开会话并在我的 mod_jk 日志文件中收到此错误
[错误] ajp_get_reply::jk_ajp_common.c (1926): (node1) 超时,等待来自 tomcat 的回复。 Tomcat 宕机、停止或网络问题(errno=110)
我亲自检查了在node1上登录的用户,然后移到了node2。
Apache 无法从 node1 获得回复时是否重定向到另一个节点,useJk 如何在这种情况下提供帮助。
---编辑01---
- 我将 UseJK 值更改为 true,但仍然很少有用户遇到突然注销的情况,我知道这是因为服务器节点发生了变化以满足用户的请求。
- 我还想知道节点上的流量是否对粘性会话有任何影响以及如何应对它。(我在所有服务器上都经历了几天的高负载)
----编辑 02 ----
- 我还想了解如何控制每个工作人员的连接数。
- 控制 ajp 连接器/连接的数量。
- apache负载均衡器的连接数与连接数的关系 JBoss 工作节点中的 ajp 连接。
- Apache 2.2.3 和带有 Tomcat 5.5 连接器的 JBoss 4.2.2 工作节点之间的最佳配置是什么。
---- 编辑03----- http://community.jboss.org/wiki/OptimalModjk12Configuration
使用上面的文章我只是想知道 Apache 的最佳价值 最大客户数 ThreadPerChild
【问题讨论】: