【发布时间】:2014-12-14 10:03:13
【问题描述】:
我们可以在 MySQL 5.6 的早期版本(例如 5.1 或 5.5)中使用 InnoDB Memcached Plugin 吗?我在网上搜索过,但找不到任何关于此的内容。
我尝试这样做,如下所示。我下载了MySQL-server-5.6.22-1.el7.x86_64.rpm,然后运行以下命令解压:
rpm2cpio MySQL-server-5.6.22-1.el7.x86_64.rpm | cpio -idmv
然后将libmemcached.so从~/usr/lib64/mysql/plugin复制到/usr/lib64/mysql/plugin,然后从这些指令here运行以下命令:
mysql> install plugin daemon_memcached soname "libmemcached.so";
但我收到以下错误:
无法打开共享库“libmemcached.so”(errno:8,此版本的服务器不支持 DAEMON 插件 daemon_memcached 的 API 版本
我当前的 MySQL 版本是:
mysql Ver 15.1 Distrib 5.5.37-MariaDB, for Linux (x86_64) using readline 5.1
有什么解决办法吗?
【问题讨论】:
-
在详细更新我的问题后,我仍然不明白为什么我的问题得到了 -1 票。
-
这可能是因为投反对票的人没有返回问题来查看它是否得到了改进。这在这里很正常。
标签: mysql innodb libmemcache