【发布时间】:2015-02-18 15:25:36
【问题描述】:
一旦我 a2enmod ssl 模块并重新启动 apache,我会收到以下错误:
Restarting web server apache2
AH00548: NameVirtualHost has no effect and will be removed in the next
release /etc/apache2/ports.conf:14
(98)Address already in use: AH00072: make_sock: could not bind to address
[::]:443
(98)Address already in use: AH00072: make_sock: could not bind to address
0.0.0.0:443
no listening sockets available, shutting down
AH00015: Unable to open logs
Action 'start' failed.
The Apache error log may have more information.
要阻止它,我可以在 ports.conf 文件中 disenmod 或注释掉以下模块行:
Listen 80
#<IfModule mod_ssl.c>
# Listen 443
#</IfModule>
<IfModule mod_gnutls.c>
Listen 443
</IfModule>
# vim: syntax=apache ts=4 sw=4 sts=4 sr noet
任何帮助将不胜感激
【问题讨论】: