【问题标题】:Receiving Error -26612: HTTP Status-Code=500 during VUGen script replay接收错误 -26612:在 VUGen 脚本重播期间 HTTP 状态代码 = 500
【发布时间】:2016-12-29 16:40:43
【问题描述】:

我目前正在使用 Oracle EBS R12.2.5 测试 HP LoadRunner 12.50。我为场景使用协议(Oracle NCA + Web – Http/HTML)为 Web 和 Oracle EBS 应用程序创建了一个简单的脚本(登录到 Web,打开 Oracle 表单,保存 oracle 表单,关闭表单并注销)和重播,但遇到以下错误。

错误 -26612:HTTP 状态代码=500(内部服务器错误)

我无法解决上述错误,虽然对脚本执行了关联,但仍然发生错误。我不熟悉使用 HP LoadRunner 为 Oracle 表单开发 VUGen 脚本。在 Runtime Settings > Browser > Browser Emulation > Use Browser > Browser Version = 11.0 & Internet Protocol > Preferences > HTTP > ‘Keep-Alive HTTP connections’被选中。

如何在不出错的情况下重播脚本?是否有任何新的关联需要手动添加?如果有的话,新的关联是什么?

提前致谢。

【问题讨论】:

    标签: oracle loadrunner


    【解决方案1】:

    最常见的原因是工艺和工具机制的结合。在流程方面,您需要明确检查预期结果。在 500 情况下最常见的情况是您未能检查积极的预期结果,将 HTTP 200 作为积极结果,然后进入下一步。但是,您可以获得 500 分,其中包含不适当的内容,以积极执行业务流程。然后你进入下一步,“Whammo!”这是一个用于脱离上下文请求的 HTTP 500。

    在您的代码中

    1. 明确检查内容中的积极预期结果。有关此内容的上下文,请参见 web_reg_*() 函数。这也包含在培训和可用教程中
    2. 当您没有找到积极的预期结果时,分支您的代码并退出迭代

    【讨论】:

      猜你喜欢
      • 1970-01-01
      • 2021-08-19
      • 1970-01-01
      • 1970-01-01
      • 2017-07-06
      • 1970-01-01
      • 1970-01-01
      • 1970-01-01
      • 1970-01-01
      相关资源
      最近更新 更多