【问题标题】:running neo4j from a remote machine从远程机器运行 neo4j
【发布时间】:2018-02-07 14:10:57
【问题描述】:

我已在 Linux 机器上安装并运行 neo4j 3.3.2。

我正在尝试从同一网络的远程 Windows 计算机访问控制台。

我在 conf/neo4j-conf 中更改了一些配置,如下所示:

dbms.connectors.default_listen_address=0.0.0.0 dbms.connector.bolt.listen_address=0.0.0.0:7687 dbms.connector.http.listen_address=0.0.0.0:7474 dbms.connector.https.listen_address=0.0.0.0:7473

我现在可以远程访问浏览器,但尝试登录时出错:

[![WebSocket connection failure. 
Due to security constraints in your web browser, the reason for the failure is not available to this Neo4j Driver. 
Please use your browsers development console to determine the root cause of the failure. 
Common reasons include the database being unavailable, using the wrong connection URL or temporary network problems. 
If you have enabled encryption, ensure your browser is configured to trust the certificate Neo4j is configured to use. WebSocket `readyState` is: 3"]]

【问题讨论】:

  • 访问console 是什么意思?是browser、cypher-shell 还是别的什么?
  • 是的,我的意思是浏览器。我已经取得了进展。我已停用“AlwaysPreTouch”选项及其下方的所有选项。现在我可以访问控制台,但登录时出现问题。我已经更新了我原来的帖子。

标签: neo4j remote-access


【解决方案1】:

你应该看看 bolt url:bolt://0.0.0.0:7687

这不是一个有效的 IP 地址,您应该将 0.0.0.0 替换为您的服务器的 IP 地址。

我想您还使用0.0.0.0 更改了配置中dbms.connectors.default_advertised_address 的值没有?

# 客户端可以访问此服务器的地址。这可能是服务器的 IP 地址或 DNS 名称,或者 # 它可能是 位于服务器前面的反向代理的地址。这个 下面的 # 个单独的连接器的设置可能会被覆盖。 dbms.connectors.default_advertised_address={在此处输入您的服务器的 IP}

【讨论】:

    猜你喜欢
    • 2011-06-22
    • 2016-04-02
    • 1970-01-01
    • 1970-01-01
    • 2013-07-25
    • 2020-02-14
    • 1970-01-01
    • 2010-11-08
    • 2015-07-30
    相关资源
    最近更新 更多