【问题标题】:Strange error with folder permissions (mkdir)文件夹权限的奇怪错误(mkdir)
【发布时间】:2015-09-09 13:29:45
【问题描述】:

我正在运行一个 nginx 服务器和 php5,但我无法让 php 中的 mkdir 正常工作。我总是收到permission denied 错误。 运行 nginx 的用户是组 www 中的 www,这同样适用于 php,我要创建新文件夹的文件夹也由 持有www。

仅当我将文件夹权限设置为 777 时才有效,而 775 则无法正常工作。

奇怪的是,当我尝试以 www 用户身份在终端中创建一个文件夹时,它可以正常工作。

任何帮助将不胜感激,因为我已经为这个错误苦苦挣扎了 2 天。

【问题讨论】:

    标签: php nginx mkdir


    【解决方案1】:

    这可能是因为PHP 模块配置有问题。您也必须在那里设置正确的用户。

    检查这个documentation。

    【讨论】:

    • 我已经在php-fpm.conf中设置了用户,是否还要更改php.ini?
    猜你喜欢
    • 2020-08-08
    • 1970-01-01
    • 2013-04-14
    • 1970-01-01
    • 1970-01-01
    • 1970-01-01
    • 1970-01-01
    • 1970-01-01
    • 1970-01-01
    相关资源
    最近更新 更多