【问题标题】:Apache will not start on mac osx after installing package php70-ssh2安装包 php70-ssh2 后,Apache 将无法在 mac osx 上启动
【发布时间】:2017-05-02 13:35:05
【问题描述】:

运行后

brew install php70-ssh2

我机器上的 apache 服务器无法启动。当我跑步时

apachectl -T

我看到了输出

httpd: Syntax error on line 170 of /private/etc/apache2/httpd.conf: Cannot load /usr/local/opt/php70/libexec/apache2/libphp7.so into server: dlopen(/usr/local/opt/php70/libexec/apache2/libphp7.so, 10): image not found

有其他人遇到过这个错误吗?有人知道解决方法吗?

【问题讨论】:

    标签: macos apache php-7


    【解决方案1】:

    在终端中,如果您输入sudo find /usr -name libphp*,您应该会在第 170 行看到与 Apache 配置文件中的路径不同的路径。在第 170 行注释掉 /private/etc/apache2/httpd.conf 中的路径并粘贴从 find 命令返回的路径。如果 find 命令没有返回任何内容或返回与 libphp7.so 不同的文件,则需要更多信息和更多故障排除。

    【讨论】:

    • 不幸的是,这个命令没有结果。如果有帮助,我相信我用自制软件安装了 php70。
    • 根本原因是 Apache 正在使用路径 /usr/local/opt/php70/libexec/apache2/libphp7.so 寻找 libphp7.so 而没有在那里找到它。在我的 Mac 上,php 库文件位于 /usr/libexec/apache2/。如果您知道在计算机上的何处可以找到此文件,请将其用于 httpd.conf 中的 LoadModule php7_module 设置,或者在 Apache 配置的路径中创建指向该文件的链接,以便在该目录中找到它,甚至将该文件复制到该目录中。
    猜你喜欢
    • 2018-06-18
    • 1970-01-01
    • 1970-01-01
    • 1970-01-01
    • 2014-08-27
    • 2015-08-27
    • 2013-05-08
    • 1970-01-01
    • 1970-01-01
    相关资源
    最近更新 更多