【发布时间】:2017-10-28 04:21:19
【问题描述】:
我将 Daphne 用于套接字和 http 连接。我正在运行 4 个工作容器,现在在 docker 容器中本地运行所有内容。
如果我尝试上传 400MB 的文件,我的 daphne 服务器会失败。它适用于最大 15MB 的小文件。
我的 docker 容器退出并显示错误代码 137。我在 daphne 日志中没有收到任何错误。 daphne 容器会死掉,但工作容器会继续运行。
有谁知道是否有办法增加对 daphne 的上传限制或我遗漏了其他东西?
我通过以下方式启动 daphne 服务器
daphne -b 0.0.0.0 -p 8001 project.asgi:channel_layer --access-log=${LOGS}/daphne.access.log
【问题讨论】:
-
Daphne 没有记录任何内容表明它可能内存不足...
-
这也是我所怀疑的。有没有办法解决这个问题,我正在使用
docker-compose up来运行我的容器。我环顾四周,看到oom-kill-disable标志传递到 docker run。但我无法使用它运行。 -
我对 docker 的了解还不够多,不能说 - 如果内存是问题,那么您将不得不找到一些方法来增加可用的内容。
-
@solarissmoke 你是对的,因为 Docker 内存不足。一旦我分配了更多内存,一切都开始工作了。
标签: python django docker daphne