【问题标题】:Unable to load wsgi module on Apache 2.4.9无法在 Apache 2.4.9 上加载 wsgi 模块
【发布时间】:2015-05-27 10:38:16
【问题描述】:

我在 Windows 8.1 上安装了 python 32 位版本 2.7.9,在我的 wamp 服务器上安装了 apache 2.4.9。我正在尝试加载 wsgi 模块。我已将文件 mod_wsgi.so 复制到路径 C:\wamp\bin\apache\apache2.4.9\modules 中。我还编辑了 httpd.conf 并添加了 LoadModule wsgi_module modules/mod_wsgi.so。

我得到的错误是:

httpd.exe: Syntax error on line 181 of C:/wamp/bin/apache/apache2.4.9/conf/httpd
.conf: Cannot load modules/mod_wsgi.so into server: %1 is not a valid Win32 appl
ication.

我做错了什么?或者有什么我没有做的。

【问题讨论】:

  • 您不能随意复制库。 .so 文件是 Linux 共享库;你几乎肯定需要一个 DLL。您需要为您的 Windows 版本和架构安装正确的版本。
  • 我查过了。我安装了正确的。
  • 您从哪里获得 mod_wsgi 二进制文件,它是您的 Apache 的正确架构和编译器变体吗?你有没有仔细阅读github.com/GrahamDumpleton/mod_wsgi/blob/develop/win32/…

标签: django apache module wamp wsgi


【解决方案1】:

当我有 cgi 模块并尝试加载 wsgi 模块时,我遇到了同样的错误,问题是我没有启用 cgi,所以它是开箱即用的,所以只需禁用它并尝试重新启动 wamp

p>

【讨论】:

    猜你喜欢
    • 1970-01-01
    • 2018-01-18
    • 1970-01-01
    • 2013-04-09
    • 2017-06-06
    • 1970-01-01
    • 2014-03-18
    • 2021-11-28
    • 2011-09-21
    相关资源
    最近更新 更多