【问题标题】:SQL error when trying to move Joomla site to new account尝试将 Joomla 网站移动到新帐户时出现 SQL 错误
【发布时间】:2014-10-25 17:55:09
【问题描述】:

我有一个网站,我正试图从 GoDaddy 的“传统”托管帐户转移到新的“cpanel”托管帐户。迁移的原因是我们希望能够从该站点销售 MP3,并且为了将这些文件放在主目录中,我们需要一个 cpanel 帐户(根据 GoDaddy)。

我们虔诚地使用 Akeeba 备份和管理工具,并且对这些程序中的每一个都没有任何问题...

我使用 Akeeba kickstart 将该站点的副本移至朋友的测试环境(不同的主机),没有问题。但是,在将存档文件和 kickstart 文件移动到 GoDaddy 上的新 cpanel 帐户后,我收到了一个数据库恢复错误(在通过预安装屏幕后),并已联系支持 GoDadddy 和 Akeeba(这太棒了,但他们周末不营业)。

以下是我为尝试解决此问题而采取的步骤以及结果:

  1. 创建了数据库、DB 用户,并在 cpanel 中关联了它们 新的 GoDaddy 托管帐户。
  2. 已上传 kickstart.php 文件和 akeeba 备份存档 (.jpa 文件)。
  3. 通过转到 URL 并通过 预安装页面

接下来我收到以下错误:

还原数据库时出错。错误信息可以 可以在下面找到。单击此对话框右上角的 × 按钮 消息关闭它并返回数据库恢复页面。

SQL=显示来自xxxx_usergroups 的完整列

注意:虽然总是出现 SQL=SHOW FULL COLUMNS FROM 错误,但有时表会有所不同

以下是我迄今为止尝试过的其他事情:

  1. 完全清除站点并使用 kickstart 重新开始该过程 文件和存档文件 - 结果:仍然出错
  2. 清除站点,将 php 版本从 5.4 更改为 5.3 并开始 使用 kickstart 文件和存档文件再次处理 - 结果仍然 得到错误
  3. 在 cpanel 中创建了一个新的 DB 用户,以确保该用户拥有完整的 数据库权限,将此用户与数据库相关联,并开始 使用 kickstart 文件和存档文件再次处理: - 结果:仍然 得到错误
  4. 在 Web 和 Akeeba 网站上搜索其他可能的修复 - 结果:是 找不到任何其他有用的东西

Akeeba 让我查看 GoDaddy 是否有每小时/分钟的最大查询限制。 GoDaddy 可以; 1000. 根据 GoDaddy 的说法,我改变这一点的唯一方法是通过 php.ini 文件,但除此之外他们无法提供帮助。

我从未创建过 php.ini 文件,也不知道需要在该文件中添加什么代码来解决此问题。我已经在网上查看了 PHP 的资源,但由于这不是我的专长,所以当我试图弄清楚这个 ini 文件中需要哪些命令时,我完全迷失了。再说一次,Akeeba 周末休息,所以我希望在那之前得到一些帮助。

谢谢!

【问题讨论】:

    标签: php mysql joomla


    【解决方案1】:

    如果您被允许编辑自己的 php 配置,则在您的 cPanel 中,您应该在软件/服务下有一个 php 配置图标。从那里您需要将 MAX_QUERIES_PER_HOUR 更改为您需要的任何值。

    【讨论】:

    • 谢谢!我能够进入那里并查看允许更改的设置列表,但我无法通过单击该图标进行更改。我需要将它们设置在 php.ini 文件中,我不确定我需要使用哪些代码 - 如果不是它们的组合。以下是列表:register_globals、file_uploads、upload_max_filesize、asp_tags、safe_mode、include_path、max_execution_time、max_input_time、memory_limit、session.save_path
    猜你喜欢
    • 1970-01-01
    • 1970-01-01
    • 1970-01-01
    • 1970-01-01
    • 1970-01-01
    • 1970-01-01
    • 2013-03-06
    • 1970-01-01
    • 1970-01-01
    相关资源
    最近更新 更多