【问题标题】:form on this page has more than 1000 fields此页面上的表单有 1000 多个字段
【发布时间】:2016-11-12 08:20:48
【问题描述】:

当我尝试导出数据库时,我的本地主机上有数据库,它给了我这个错误

警告:此页面上的表单包含 1000 多个字段。提交时, 由于 PHP 的 max_input_vars,某些字段可能会被忽略 配置。

所以我将max_input_vars = 1000 更改为max_input_vars = 10000 现在我可以下载数据库了,但是在服务器上导入需要很长时间,而且它可能会损坏我的数据库。

还有其他选项可以让我的数据库正常工作吗?我有大约 450 个表,有些表有大约 4000-5000 个条目

我正在使用 xammp 服务器在 Windows 7 上工作,并且我已经为 magento 网站创建了这个数据库。

【问题讨论】:

  • 您有一个包含 1000 列的表?我认为您需要查看规范化。数据库表不是电子表格,也不是“表格”
  • 您的问题与mysql 或localhost 完全无关,并且错误消息非常清楚地表明它确实与php、html 和@987654325 有关@。不要乱加标签,一定要提供相关标签。这符合你自己的利益。

标签: php html forms


【解决方案1】:

这是 100% 的工作

首先在php.ini文件中找到max_input_vars 并更改为:

;max_input_vars = 1000 

到

max_input_vars = 1000

这在了解更多please visit video link 时工作正常。

【讨论】:

    【解决方案2】:

    以下是我的解决方案:

    首先,确保您正在编辑正确的php.ini 文件。为此,您可以使用 phpinfo() 检查它是什么。

    然后重启php重新加载php.ini,根据你的安装方式,可以这样:

    brew services restart php72

    重启 apache 以确保:

    sudo apachectl -k restart

    然后将以下语句放入 test.php 文件中:

    echo ini_get('max_input_vars'); 并检查它。

    此时您会看到它已正确更新。

    如果之后 phpmyadmin 仍然显示错误,则应该用力刷新 phpmyadmin 页面:可以使用 CMD+SHIFT+R 在 Mac 上。

    原因是 phpmyadmin 的本地 javascript 文件从 php 传递了 max_input_vars 的值,并负责决定是否显示错误。因此,如果 javascript 本地文件由于缓存原因未更新,那么您只需刷新它,问题就消失了:)

    【讨论】:

      【解决方案3】:

      您应该提供有关您所在的系统以及您尝试导出数据库的方法的更多信息,否则答案无法具体。

      mysqldump 是您导出所需要的。

      在 Linux 上(也可能在 Apple 计算机上)你可以简单地使用:

      mysqldump -u YOUR_USER -p YOUR_DATABASE > DESIRED_FILE_NAME.sql
      

      mysqldump 也应该适用于 Windows。

      【讨论】:

        猜你喜欢
        • 2023-03-16
        • 1970-01-01
        • 1970-01-01
        • 2012-06-11
        • 2011-01-27
        • 1970-01-01
        • 2010-09-10
        • 2014-06-03
        • 1970-01-01
        相关资源
        最近更新 更多