【发布时间】:2011-02-25 19:25:39
【问题描述】:
我在 Tomcat 上的 JSF webapp 位于 http://www.deprem.gov.tr:8080/pro1/bir.jsf 中 直接到localhost,什么都找不到。
可能的原因是什么?
【问题讨论】:
我在 Tomcat 上的 JSF webapp 位于 http://www.deprem.gov.tr:8080/pro1/bir.jsf 中 直接到localhost,什么都找不到。
可能的原因是什么?
【问题讨论】:
几个可能的原因:
localhost:8080 重定向。也许在某些过滤器中?www.deprem.gov.tr 由您的DNS 服务器解析为localhost。www.deprem.gov.tr 在您的etc/hosts 文件中解析为localhost。这不一定与 JSF 或 Tomcat 有关。这只是一个错误配置:)
【讨论】:
正如@BalusC 所说,这是一个配置问题。我建议您在项目文件中搜索“www.deprem.gov.tr”,如果它不在主机文件中。您可能会在硬编码的地方看到它。
【讨论】: