【发布时间】:2016-04-14 14:10:55
【问题描述】:
我可以毫无问题地将流程部署到独立安装的 Apache Flink(带有一个 JobManager 和多个 TaskManager):
bin/flink run -m example-app-1.stag.local:6123 -d -p 4 my-flow-fat-jar.jar <flow parameters>
但是当我运行相同的命令并部署到独立 HA 集群时,此命令会引发错误:
------------------------------------------------------------
The program finished with the following exception:
org.apache.flink.client.program.ProgramInvocationException: The program execution failed: JobManager did not respond within 60000 milliseconds
at org.apache.flink.client.program.Client.runDetached(Client.java:406)
at org.apache.flink.client.program.Client.runDetached(Client.java:366)
at org.apache.flink.client.program.DetachedEnvironment.finalizeExecute(DetachedEnvironment.java:75)
at org.apache.flink.client.program.Client.runDetached(Client.java:278)
at org.apache.flink.client.CliFrontend.executeProgramDetached(CliFrontend.java:844)
at org.apache.flink.client.CliFrontend.run(CliFrontend.java:330)
at org.apache.flink.client.CliFrontend.parseParameters(CliFrontend.java:1189)
at org.apache.flink.client.CliFrontend.main(CliFrontend.java:1239)
Caused by: org.apache.flink.runtime.client.JobTimeoutException: JobManager did not respond within 60000 milliseconds
at org.apache.flink.runtime.client.JobClient.submitJobDetached(JobClient.java:221)
at org.apache.flink.client.program.Client.runDetached(Client.java:403)
... 7 more
Caused by: java.util.concurrent.TimeoutException: Futures timed out after [60000 milliseconds]
at scala.concurrent.impl.Promise$DefaultPromise.ready(Promise.scala:219)
at scala.concurrent.impl.Promise$DefaultPromise.result(Promise.scala:223)
at scala.concurrent.Await$$anonfun$result$1.apply(package.scala:190)
at scala.concurrent.BlockContext$DefaultBlockContext$.blockOn(BlockContext.scala:53)
at scala.concurrent.Await$.result(package.scala:190)
at scala.concurrent.Await.result(package.scala)
at org.apache.flink.runtime.client.JobClient.submitJobDetached(JobClient.java:218)
... 8 more
Active Job Manager 将以下错误写入日志:
2016-04-14 13:54:44,160 WARN akka.remote.ReliableDeliverySupervisor - Association with remote system [akka.tcp://flink@127.0.0.1:62784] has failed, address is now gated for [5000] ms. Reason is: [Disassociated].
2016-04-14 13:54:46,299 WARN org.apache.flink.runtime.jobmanager.JobManager - Discard message LeaderSessionMessage(null,TriggerSavepoint(5de582462f334caee4733c60c6d69fd7)) because the expected leader session ID Some(72630119-fd0a-40e7-8372-45c93781e99f) did not equal the received leader session ID None.
所以,我不明白什么会导致这样的错误?
如果需要更多信息,请告诉我。
附言
从 Flink Dashboard 部署适用于独立 HA 集群。仅通过 Flink CLI 部署时出现此类问题。
更新
我清理了 Zookeeper,清理了磁盘上 Flink 使用的目录,重新部署了 Flink Standalone HA 集群。然后我尝试使用bin/flink run 命令运行流程。如您所见,JobManager 只写了一行关于问题的内容(参见 flink--jobmanager-0-example-app-1.stag.local.log)。
所有 JobManager 和 TaskManager 使用相同的flink-conf.yaml:
jobmanager.heap.mb: 1024
jobmanager.web.port: 8081
taskmanager.data.port: 6121
taskmanager.heap.mb: 2048
taskmanager.numberOfTaskSlots: 4
taskmanager.memory.preallocate: false
taskmanager.tmp.dirs: /flink/data/task_manager
blob.server.port: 6130
blob.storage.directory: /flink/data/blob_storage
parallelism.default: 4
state.backend: filesystem
state.backend.fs.checkpointdir: s3a://example-flink/checkpoints
restart-strategy: none
restart-strategy.fixed-delay.attempts: 2
restart-strategy.fixed-delay.delay: 60s
recovery.mode: zookeeper
recovery.zookeeper.quorum: zookeeper-1.stag.local:2181,zookeeper-2.stag.local:2181,zookeeper-3.stag.local:2181
recovery.zookeeper.path.root: /example/flink
recovery.zookeeper.storageDir: s3a://example-flink/recovery
recovery.jobmanager.port: 6123
fs.hdfs.hadoopconf: /flink/conf
看来,独立 HA 集群配置正确。
更新 2
仅供参考:我想按照here 的描述安装独立 HA 集群。不是 YARN HA 集群。
更新 3
这是由bin/flink CLI 创建的日志:flink-username-client-hostname.local.log。
【问题讨论】:
-
你能粘贴完整的jobmanager日志吗?
-
您是否在 cli 使用的
flink-conf.yaml中设置了正确的 HA 设置(因此是FLINK_HOME/conf/flink-conf.yaml中的那个)? -
@TillRohrmann 我添加了日志和
flink-conf.yaml。有什么问题吗? -
你是对的,这不仅适用于yarn集群,也适用于standalone集群。因此,无论何时使用 HA,都必须设置这些值。
标签: apache-flink