【问题标题】:ER_NOT_SUPPORTED_AUTH_MODE - sails 1.0 and MySQL 8.0ER_NOT_SUPPORTED_AUTH_MODE - 帆 1.0 和 MySQL 8.0
【发布时间】:2018-04-27 08:42:45
【问题描述】:

我正在尝试将 SailsJS 与 MySQL 连接

default: {
  adapter: require('sails-mysql'),
  url: 'mysql://root:root@localhost/ventas'
},

但每当我进行“起帆”时,我都会收到以下错误:

error: A hook (`orm`) failed to load!
error:
error: { error:
   { Error: ER_NOT_SUPPORTED_AUTH_MODE: Client does not support authentication protocol requested by server; consider upgrading MySQL client
    at Handshake.Sequence._packetToError (C:\ticket\node_modules\mysql\lib\protocol\sequences\Sequence.js:48:14) }

我只是使用sails自带的web应用模板,没有添加代码。

有什么想法吗?

【问题讨论】:

    标签: mysql sails.js


    【解决方案1】:

    问题可能与加密密码有关。 MySQL 8.0 使用caching_sha2_password。您需要将其更改为 mysql_native_password:

    ALTER USER 'user' identified with mysql_native_password BY 'password';
    

    【讨论】:

      【解决方案2】:

      问题来自mysql,需要将插件改为mysql_native_password,然后flush privileges;,见here和here。

      【讨论】:

        【解决方案3】:

        将密码设置为大写、小写、数字和一个特殊字符,长度为 8 个字母。

        【讨论】:

          猜你喜欢
          • 2017-12-10
          • 2019-03-07
          • 1970-01-01
          • 2022-11-13
          • 2020-08-16
          • 2019-11-01
          • 2018-11-10
          • 2021-11-18
          • 1970-01-01
          相关资源
          最近更新 更多