【问题标题】:my godaddy hosted orchard website is thrownig The page cannot be displayed because an internal server error has occurred我的godaddy托管果园网站被抛出ig页面无法显示,因为发生了内部服务器错误
【发布时间】:2012-10-31 09:08:04
【问题描述】:

我的 Godaddy 托管果园网站正在抛出: "由于发生内部服务器错误,页面无法显示"

有人遇到过这个问题吗?

【问题讨论】:

  • 最可能的原因是配置错误。在您的网站开始引发此错误之前,您是否更改了任何内容?
  • 它在我的本地机器上运行,我们将它托管在 azure 云中,它也在运行,styfox @ azure 和 Godaddy 托管在 Styfox @ godaddy
  • 哪个报错了?如果两者都不是,请先查看本地 IIS 和 ASP 日志文件。附言任何主文件/包含中的语法错误都可能导致此行为。
  • 在本地和天蓝色运行良好。但它在 Godaddy 托管上抛出错误
  • 查看App_Data/Logs中的日志文件。

标签: iis-7 orchardcms web-hosting


【解决方案1】:

我收到了同样的错误消息,但我没有运行 Orchard。我已将 ASP.NET 4.5 站点从托管的 Rackspace 服务器移动到 GoDaddy。我发现问题与web.config中的一个标签有关;类似这样:

<system.webServer>
    <staticContent>
        <mimeMap fileExtension=".woff" mimeType="application/x-woff" />
    </staticContent>
</system.webServer>

一旦我删除了标签,我就不再收到错误了。由于这个应用程序是由其他人构建的,我不确定我是否需要弄清楚如何重新插入标签。

希望这对通过 Google 搜索偶然发现此问题的其他人有所帮助。

【讨论】:

    【解决方案2】:

    简短的回答,检查您正在加载 Orchard 的 .NET 版本。如果您使用的是 v1.6,那么您需要 .NET 4.0。

    当我将 .Net 2.0 网站更新到 Orchard 时,这发生在我身上。客户使用的托管公司是共享托管,我所有的测试环境都可以正常运行该站点。直到我让客户询问托管公司他们使用的是什么版本,一分钱才掉了下来。如果您使用 SqlCE,还要检查 App_Data 文件夹的权限。

    【讨论】:

      【解决方案3】:

      这可能是 App_Data 文件夹的权限设置造成的。您可能需要授予对该文件夹的写入权限。

      【讨论】:

        猜你喜欢
        • 1970-01-01
        • 2015-08-24
        • 1970-01-01
        • 1970-01-01
        • 1970-01-01
        • 1970-01-01
        • 1970-01-01
        • 1970-01-01
        • 1970-01-01
        相关资源
        最近更新 更多