【发布时间】:2021-08-10 10:54:37
【问题描述】:
【问题讨论】:
-
这看起来是正确的方法来设置为拒绝公共访问并允许 Azure 服务。
标签: azure azure-sql-database firewall
【问题讨论】:
标签: azure azure-sql-database firewall
当拒绝公共网络访问设置为是时,仅允许通过私有终结点进行连接。当此设置为“否”(默认)时,客户可以使用公共终结点(使用基于 IP 的防火墙规则或使用基于虚拟网络的防火墙规则)或专用终结点(使用 Azure 专用链接)进行连接
您必须创建专用终结点才能将函数连接到 SQL Server,因为在逻辑服务器上没有任何现有专用终结点的情况下,任何将“拒绝公共网络访问”设置为“是”的尝试都会失败,并显示类似于以下内容的错误消息:
Error 42102
Unable to set Deny Public Network Access to Yes since there is no private endpoint enabled to access the server.
Please set up private endpoints and retry the operation.
https://docs.microsoft.com/en-us/azure/azure-sql/database/connectivity-settings
【讨论】: