【问题标题】:Varnish seems to have trouble keeping the connection with the backend (error 503)Varnish 似乎无法保持与后端的连接(错误 503)
【发布时间】:2013-01-28 00:09:11
【问题描述】:

我在本地环境中一直在努力解决这个问题已经有一段时间了。我一直在寻找各种不同的解决方案。

设置:我在配置文件中创建一个后端,指向一个没有缓存(通过)的外部网站。

行为:随机关闭后端连接并显示“错误 503 服务不可用”消息。

我有一个由 Amazon EC2 提供的简单网页。我使用 Varnish 重定向我的电话。我在浏览器中按 F5,有时它可以工作,有时不能。使用 varnishlog,我一直在试图弄清楚发生了什么:唯一有意义的是它说“BackendClose”的那一行。之后,所有后续请求都失败。 (另外,我还配置了其他后端,它工作正常。)

另外,我一直在尝试使用保持活动/会话长度,但到目前为止没有任何效果。据我了解,似乎与后端的连接已关闭(可能由于某种原因通过亚马逊),但清漆等待一段时间才能恢复它。

所以,如果有人有一些建议,我很乐意尝试。

清漆版本:varnish-3.0.2 修订版 cbf1284

【问题讨论】:

    标签: backend varnish


    【解决方案1】:

    在试图找出问题出在哪里之后,我终于弄明白了。

    似乎有什么东西因为某种原因阻止了 ip。在检查防火墙随机阻止一些数据包和不同的交换机策略后,我发现问题是因为我的机器有第二个以太网配置。我不知道为什么它在那里,所以我删除了它。从那以后,这个问题就消失了。

    感谢帮助我解决这个问题的网络人员,因为我快疯了 :P 最后,这不是清漆问题。下一次,我会尝试在不同的机器和环境上做很多不同类型的测试,然后再浪费这么多时间。

    【讨论】:

      猜你喜欢
      • 2016-06-19
      • 2021-07-29
      • 2016-01-17
      • 2020-06-03
      • 1970-01-01
      • 2011-03-12
      • 2020-11-04
      • 2013-04-12
      • 2012-06-16
      相关资源
      最近更新 更多