【问题标题】:ASP.NET deployed application stops respondingASP.NET 部署的应用程序停止响应
【发布时间】:2015-11-06 16:51:37
【问题描述】:

我们有一个在 IIS 7 上运行的 ASP.NET 部署应用程序。最近我们开始遇到网站问题,通常在高流量时间开始,问题是页面停止加载而没有显示错误。它基本上继续旋转并且不加载。 IIS 重置通常会解决此问题,但我们已尝试一切方法来解决此问题,但均未成功。以下是关于我们已经尝试过的其他信息。我可以通过将 25 个并发用户运行到登录页面来有意地将网站置于此状态,之后我将不得不重置 iis,因为它会停止响应。我认为这可能与 IIS 中的设置有关。最大并发连接数设置为默认值 4294967295。有点迷失在这里。

  • 我们在 IIS 上打开了失败的日志跟踪。错误日志中的数据没有提供任何结论性的信息。这可能部分与请求没有完全失败有关,因此没有创建日志。大多数错误是根据页面响应时间收集的。
  • 我还查看了应用程序池和主机日志文件,没有发现任何异常

【问题讨论】:

    标签: asp.net windows iis-7 production-environment


    【解决方案1】:

    25 个并发用户不算什么。什么是后端堆栈?这里没有列出太多细节,但我会从查看请求所在的每个阶段开始,此外还启用失败的请求跟踪。 Mike(以前来自 IIS 团队)对此有很好的描述,但简而言之:

    Troubleshoot hanging requests on IIS in 3 steps

    查看请求

    %windir%system32inetsrvappcmd 列表请求 /elapsed:30000

    启用失败的请求跟踪(当然如果不使用默认网站,请修改)

    %windir%system32inetsrvappcmd 配置跟踪“默认网站”/enablesite %windir%system32inetsrvappcmd 配置跟踪“默认网站”/enable /path:test.aspx /timeTaken:00:00:30

    那么希望你可以通过

    找到一些细节 appcmd 列表跟踪 | findstr "yourpage.aspx"

    【讨论】:

      猜你喜欢
      • 1970-01-01
      • 2018-05-22
      • 2021-10-15
      • 1970-01-01
      • 1970-01-01
      • 1970-01-01
      • 1970-01-01
      • 1970-01-01
      • 1970-01-01
      相关资源
      最近更新 更多