【发布时间】:2014-01-09 14:57:12
【问题描述】:
我正在尝试在 IIS 中启动我的网站,每当我尝试启动我的网站时,我都会收到以下错误
无法在计算机上启动服务 w3svc
我尝试启动“万维网发布服务”,但无法启动它:
错误 1068:依赖服务或组启动失败
同时,当我检查我的日志时,我发现了这个错误,
World Wide Web Publishing Service 服务依赖于 HTTP 服务,该服务因以下错误而无法启动:
该服务无法启动,原因可能是它已被禁用或没有与之关联的已启用设备。
请帮助我,我被这个错误严重抓住了,我花了一周时间研究这个错误,但还没有找到解决方案。
【问题讨论】:
-
禁用很容易检查 - 启动
services.msc并检查以确保World Wide Web Publishing Service未被禁用。依赖可能包括Windows Activation Service、RPC等。 -
我的万维网发布服务未被禁用。我已经从 services.msc 重新检查了它
-
你在 HTTP 日志中看到了吗,通常在这里找到:%systemroot%\system32\logfiles\HTTPERR
-
我找到了一个解决方案,我已经发布了。谢谢你们的帮助
-
使用这篇文章serverfault.com/questions/210903/…解决了对我来说类似的错误(使用 VS2012 分析工具引起的)