【问题标题】:IIS w3svc errorIIS w3svc 错误
【发布时间】:2014-01-09 14:57:12
【问题描述】:

我正在尝试在 IIS 中启动我的网站,每当我尝试启动我的网站时,我都会收到以下错误

无法在计算机上启动服务 w3svc

我尝试启动“万维网发布服务”,但无法启动它:

错误 1068:依赖服务或组启动失败

同时,当我检查我的日志时,我发现了这个错误,

World Wide Web Publishing Service 服务依赖于 HTTP 服务,该服务因以下错误而无法启动:
该服务无法启动,原因可能是它已被禁用或没有与之关联的已启用设备。

请帮助我,我被这个错误严重抓住了,我花了一周时间研究这个错误,但还没有找到解决方案。

【问题讨论】:

  • 禁用很容易检查 - 启动 services.msc 并检查以确保 World Wide Web Publishing Service 未被禁用。依赖可能包括Windows Activation Service、RPC等。
  • 我的万维网发布服务未被禁用。我已经从 services.msc 重新检查了它
  • 你在 HTTP 日志中看到了吗,通常在这里找到:%systemroot%\system32\logfiles\HTTPERR
  • 我找到了一个解决方案,我已经发布了。谢谢你们的帮助
  • 使用这篇文章serverfault.com/questions/210903/…解决了对我来说类似的错误(使用 VS2012 分析工具引起的)

标签: windows http iis service


【解决方案1】:

经过一周的努力,我终于找到了解决方案。我列出了解决错误所遵循的步骤:

  1. 确认“Windows Management Instrumentation”已启动且其启动类型设置为automatic。

  2. 还要确保为万维网发布服务启动了以下依赖项服务:

    • Windows 进程激活服务
    • 远程过程调用 (RPC)
    • DCOM 服务器进程启动器
    • RPC 端点映射器。
  3. 打开注册表,导航到[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\HTTP]:
    a) 双击Start,将值数据从4(禁用)更改为3(自动)。
    b) 如果该键存在,则删除"NoRun" 键。

  4. (警告:首先备份任何 IIS 网站配置)。从“打开或关闭Windows功能”中卸载“Internet信息服务”和“Windows进程激活服务(如果已安装)”并重新启动您的PC。

  5. 在 CMD 中输入以下命令并回车:

    net start http
    

现在它会通知您服务已经在运行。

  1. 从“打开或关闭 Windows 功能”重新安装 Internet 信息服务。

  2. 启动 IIS,我的网站现在已经启动,不再出现“w3svc 服务未运行错误”。

【讨论】:

  • 我遇到了同样的问题,但重新启动不起作用。我也无法将网站添加到 IIS,I followed this answer,它解决了我的问题。
  • 3 年后。 Windows 10。完美运行。
【解决方案2】:

至于我 - 我刚刚重新启动计算机。

【讨论】:

  • 你认为这应该是一个答案吗?
  • @PareshMayani 我有同样的错误,我的回答可能对我有帮助,也可以帮助其他有此错误的人。
  • 是的,有时这是最好的解决方案
【解决方案3】:

确保这两个服务正在运行并且它们的启动类型是自动的。如果它们被禁用并且没有运行,请右键单击它们并转到属性并从那里更改。

  1. Windows 进程激活服务
  2. 全球网络发布服务。

【讨论】:

  • IIS 也依赖于 Windows Process Activation Service,如果该服务关闭,则 IIS 将无法启动。
【解决方案4】:

以管理员身份运行 cmd。输入iisreset。就是这样。

【讨论】:

  • 正在尝试停止... Internet 服务已成功停止 正在尝试启动... 重新启动尝试失败。 IIS Admin Service 或 World Wide Web Publishing Service,或依赖于它们的服务无法启动。该服务或相关服务可能在启动过程中出错或被禁用。
  • 尝试通过 Administrator 权限帐户登录并执行相同操作。
  • 同样的原因我无法重启
【解决方案5】:

转到任务管理器 --> 进程并手动停止 W3SVC 进程。完成此操作后,重新启动 IIS 时该进程应正常启动

【讨论】:

  • 使用 sysinternals 的 Process Explorer 更容易,更容易找到进程。
【解决方案6】:

在我的情况下,IIS 突然停止工作,之后 Windows 进程激活服务无法重新启动。

解决这个问题的方法是:

  1. 在windows任务管理器的服务标签中找到WAS服务
  2. 在上下文菜单中选择转到处理
  3. Kill 进程(其名称将是 svchost.exe)
  4. 重启 Windows 进程激活服务

希望对你有用。

【讨论】:

  • 嗨,我没有列出该服务。你知道我该如何安装它吗?
【解决方案7】:

在我的情况下,它是 C:\Windows\System32\inetsrv\config\applicationHost.config 有问题。 我在这个文件中有一个“system.web”部分导致了这个问题。删除了该部分,一切都开始工作了

【讨论】:

    【解决方案8】:

    我的服务器上遇到了同样的问题。请按照以下步骤操作 -

    1. 打开命令提示符(以管理员身份运行)
    2. 键入 IISReset 并回车。

    它有效并解决了我的问题。

    【讨论】:

      【解决方案9】:

      我在 Windows 更新后遇到了这个问题。 Windows Process Activation Service 是 W3SVC 的依赖服务。首先,确保 Windows Process Activation Service 正在运行。就我而言,它没有运行,当我尝试手动运行它时,出现以下错误。

      Windows Process Activation Service 错误2:系统找不到指定的文件

      问题似乎是,Windows 向 WAS 服务启动参数添加了不正确的参数。我使用以下步骤解决了这个问题:

      • 启动 regedit(只需在 start 中输入)导航到

      • HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WAS\Parameters

      • 删除 NanoSetup 变量。此变量阻止 WAS 启动

      • 使用任务管理器启动 WAS 服务

      • 现在启动 W3SVC 服务

      • 您现在可以再次在 IIS 中启动您的网站

      我在this堆栈溢出线程中找到了上述WPA服务解决方案。

      【讨论】:

        【解决方案10】:

        以上答案都没有帮助我。

        原来我的Net.Tcp 端口共享服务被禁用了。我把它的启动改为手动,启动了服务,然后 IISRESET 工作了。

        我还验证了Services中启动了以下依赖服务([windows]+[r] services.msc):

        • 万维网发布服务
        • Windows 进程激活服务
        • 远程过程调用 (RPC)
        • DCOM 服务器进程启动器
        • RPC 端点映射器
        • Net.Msmq 侦听器适配器
        • Net.Pipe 侦听器适配器
        • Net.Tcp 侦听器适配器
        • Net.Tcp 端口共享服务

        我通过检查万维网发布服务的所有依赖项和子依赖项并确保每个服务都已启用和启动,找到了这个解决方案。

        要自己验证所有服务,请执行以下操作:

        1. 打开服务(只需在 Windows 10 的开始菜单中搜索即可)
        2. 查找 万维网发布服务
        3. 右键单击服务,然后单击“属性”
        4. 点击依赖项标签
        5. 检查两个框中的每个系统组件并验证每个服务是否已启动(在服务中)。
        6. 对每个依赖项的依赖项重复步骤 3-5,直到用完子依赖项

        Service Properties - Dependencies Tab

        【讨论】:

        • 这对我帮助很大,原来万维网发布服务没有启动,因为 Windows 进程激活服务没有启动,当我尝试手动启动它说它无法启动时磁盘空间不足。原来服务器没有任何空间,我没有注意到。
        【解决方案11】:

        对我来说解决方案很简单,C盘上没有空间,一旦删除了一些旧文件,我就能够执行IISReset并且所有服务都成功启动。

        【讨论】:

          【解决方案12】:

          这种情况可能比较少见,但是……

          如果您使用自定义 AppPool 身份配置,请务必检查 AppPool 是否正在运行。它可能被关闭,因为凭据无效(通常是由于密码过期)。更新您的凭据并启动 AppPool。

          【讨论】:

            【解决方案13】:

            我知道这篇文章很旧,但我收到了这个错误。原来万维网发布服务已被禁用。

            1. 单击“开始”,在“搜索”框中键入“服务”,然后单击“服务”。
            2. 滚动直到找到已停止或禁用的万维网发布服务。
            3. 右键单击该服务,然后单击“属性”。
            4. 单击启动类型列表,然后单击自动。
            5. 单击应用,然后单击确定。

            【讨论】:

              【解决方案14】:

              之后我设法解决了:

              1. Ctrl+Shift+Esc = 打开任务管理器
              2. 在“进程”选项卡中找到“IIS 工作进程”并 完成它!
              3. 以管理员身份在 cmd 上运行。输入 iisreset。

              准备好了!开心点!

              【讨论】:

                猜你喜欢
                • 2010-09-29
                • 1970-01-01
                • 1970-01-01
                • 2015-08-30
                • 2020-08-03
                • 2015-12-16
                • 2010-12-17
                • 1970-01-01
                • 2015-03-27
                相关资源
                最近更新 更多