【问题标题】:Saltstack Halite Error! Failed to run command:Saltstack 石盐错误!运行命令失败:
【发布时间】:2015-02-02 21:52:35
【问题描述】:

我设置了一个盐主服务器,目前我正在测试连接了两个仆从。我可以直接从 salt 主机运行状态和 salt 模块命令,没有任何问题。

我按照文档安装并设置了halite。我以用户身份登录并且能够毫无问题地看到列表中的奴才,但是我尝试使用 halite web ui 运行的任何命令都失败了。

这是我的主配置中的 pam 和 halite 部分:

external_auth:
  pam:
    ubuntu:
      - grains.*
      - status.*
      - sys.*
      - test.*
      - cp_bakfile.*
      - ipt_config.*
      - '@runner'
      - '@wheel'
    adam:
      - .*
      - '@runner'
      - '@wheel'
    cfadmin:
      - .*
      - '@runner'
      - '@wheel'

halite:
  level: 'debug'
  server: 'cherrypy'
  host: '0.0.0.0'
  port: '8080'
  cors: False
  tls: False
  certpath: '/etc/pki/tls/certs/localhost.crt'
  keypath: '/etc/pki/tls/certs/localhost.key'
  pempath: '/etc/pki/tls/certs/localhost.pem'

当我尝试运行命令时,我以用户 Adam 身份登录:

supervisord.restart all on my minion。

错误如下:

错误!无法运行命令:supervisord.restart on target:myminion

有人知道我应该检查什么或我可能做错了什么吗?

master 和 minions 都在 Amazon EC2 上,ubuntu 14.04。

【问题讨论】:

  • 看起来halite 没有给你一个特定的错误。当您从 cli 运行相同的类/方法时,您会得到什么?

标签: amazon-ec2 salt-stack


【解决方案1】:

这个问题很老了,但万一其他人遇到这个问题,halite 项目已被弃用,不再开发。

https://github.com/saltstack/halite

【讨论】:

    猜你喜欢
    • 1970-01-01
    • 1970-01-01
    • 1970-01-01
    • 1970-01-01
    • 1970-01-01
    • 1970-01-01
    • 2020-04-24
    • 2018-06-08
    • 1970-01-01
    相关资源
    最近更新 更多