【问题标题】:Faulting application name: w3wp.exe on IIS7 and PHP Windows Server 2008 x64错误的应用程序名称:IIS7 和 PHP Windows Server 2008 x64 上的 w3wp.exe
【发布时间】:2011-08-15 16:28:33
【问题描述】:

我尝试在安装了 IIS 7.5 的 Windows Server 2008 R2 x64 上运行带有 Helicon Isapi Rewrite 3 的网站。该网站在 ISAPI 模式下使用 PHP 5.2.16。对于 IIS 中的错误,我使用 request_uri.php 解决方案(参见代码)。

我得到的服务器错误是:404 - 找不到文件或目录。

在 Windows 应用程序日志中显示此消息:

错误的应用程序路径:C:\Windows\SysWOW64\inetsrv\w3wp.exe

故障模块路径:C:\Windows\SysWOW64\ntdll.dll

我尝试 DebugDiag 来查找某些内容,但它没有提供更多信息。你知道问题可能是什么吗?谢谢。

<?php
    if (isset($_SERVER['HTTP_X_REWRITE_URL']))
    {
        $_SERVER['REQUEST_URI'] = $_SERVER['HTTP_X_REWRITE_URL'];
    }
?>

【问题讨论】:

    标签: php windows-server-2008 iis-7.5 isapi-rewrite


    【解决方案1】:

    在 ISAPI 模式下运行 PHP 并不是最好的主意。它很可能会失败。请尝试在 FastCGI 模式下运行它。这应该会有所帮助。

    【讨论】:

      【解决方案2】:

      由于安全问题,找不到该文件。

      在 IIS 下的 Sites=>Authentication=>Anonymous Authentication=>Edit... 然后我将匿名用户身份转换为应用程序池身份,它再次工作。

      希望其他用户会觉得这很有帮助。

      谢谢

      【讨论】:

        【解决方案3】:

        【讨论】:

        • 您能否在链接中提供一些解释?
        猜你喜欢
        • 2010-11-15
        • 2010-12-06
        • 1970-01-01
        • 2012-10-15
        • 1970-01-01
        • 1970-01-01
        • 2013-01-03
        • 2011-12-14
        • 1970-01-01
        相关资源
        最近更新 更多