【问题标题】:SQL server 2008 with 2012 Data tools带有 2012 数据工具的 SQL Server 2008
【发布时间】:2015-06-09 14:50:56
【问题描述】:

我有一个运行 VS 2008 的 SQL Server 2008 (10.0.5500)。 我最近安装了 2012 年的数据工具,它们在 VS2012 中运行良好。 我拥有所有新功能,包在调试模式下运行完美,但我现在通过将它附加到 SQL 代理遇到了一个问题。 它说“从版本 6 到版本 3 的包迁移失败并出现错误 0xC001700A "包中的版本号无效。版本号c 不能大于当前版本号。"。"

这是因为 dtexec.exe 是从 2008 年开始使用的(100 文件夹)。我在 x86 中只有 110 文件夹的 dtexec.exe。

如果我指定此 dtexec 的特定路径,它会开始验证但会停止:

  Error: 2015-06-09 18:44:48.67
   Code: 0xC000F427
   Source: Data Flow Task SSIS.Pipeline
   Description: To run a SSIS package outside of SQL Server Data Tools you must install Merge Join of Integration Services or higher.
End Error

正在运行的集成服务是版本 10,我没有获得版本 11 的新服务,也没有看到任何运行/安装它的方法。

所有都在同一台机器上完成,包应该在它开发的机器上每晚运行。

编辑:这不是重复的,我都在 VS 调试中工作。我在问如何在没有 dtexec 的情况下安排我的包。

【问题讨论】:

  • “在没有 dtexec 的情况下安排我的包”是什么意思?您不是在 SQL Server 2008 实例上的 SQL Server 代理中创建作业吗?
  • 所以我设计了我的整个包,在 VS 2012 的调试中一切正常,我希望它每晚运行。我无法使用 dtexec 调用的当前安装的集成服务服务来执行此操作,从而使 sql 代理无法使用。在不购买新的 SQL 2012 许可证的情况下,我已经完全放弃了让它像那样工作,我永远不会让我们的客户这样做。我很确定他们甚至可以在 Visual Studio 调试模式下自动运行包,但我也怀疑这是可能的..

标签: sql-server sql-server-2008 visual-studio-2012


【解决方案1】:

SQL Server 2008 上的集成服务不支持 SSDT/Visual Studio 2010(或更高版本)包。

https://social.msdn.microsoft.com/Forums/sqlserver/en-US/5edf4335-937f-4b81-aea1-2cd2f10993f4/problem-with-deploying-ssis-2010-package?forum=sqlintegrationservices

您必须安装 SQL Server 2012 才能运行 SSDT 包。

【讨论】:

    猜你喜欢
    • 1970-01-01
    • 1970-01-01
    • 1970-01-01
    • 1970-01-01
    • 1970-01-01
    • 1970-01-01
    • 1970-01-01
    • 2015-01-18
    • 2010-12-14
    相关资源
    最近更新 更多