【问题标题】:Express application as a IIS subsite fails to load static filesExpress 应用程序作为 IIS 子站点无法加载静态文件
【发布时间】:2019-10-18 14:25:59
【问题描述】:

我正在 IIS 中使用 Express 设置 Angular Universal 应用程序,并使用本文 https://dev.to/petereysermans/hosting-a-node-js-application-on-windows-with-iis-as-reverse-proxy-397b 中所述的反向代理。如果我将我的 IIS 站点设置为 http://example.com 并将 URL 重写为 http://localhost:4000/{R:1}(节点应用程序正在侦听 4000)一切正常。

我想在 IIS 中使用一个子站点,例如http://example/abc,所以我在我的网站下设置了一个名为 abc 的应用程序,它具有上述重写规则。现在,当我浏览到 http://example.com/abc 时,浏览器正尝试从 http://example.com 加载 js/css 文件,这会导致 404 错误。难道我做错了什么?我以前在 IIS 中将 Angular 站点设置为子站点(不是通用的),它可以正确加载 js/css 文件。

【问题讨论】:

  • 您的 Angular 应用程序是否使用 "baseHref": "/abc"?
  • 禁用反向代理规则并尝试只浏览托管的 node express 应用程序。您想在 iis 中托管简单的 node js 应用程序还是 node js express 应用程序?

标签: angular express iis angular-universal


【解决方案1】:

在构建时尝试使用--deploy-url 选项

ng build --prod --deploy-url /abc

【讨论】:

    猜你喜欢
    • 1970-01-01
    • 1970-01-01
    • 1970-01-01
    • 2017-02-11
    • 2017-12-23
    • 1970-01-01
    • 1970-01-01
    • 1970-01-01
    • 1970-01-01
    相关资源
    最近更新 更多